Download

Number keys seem to not work

Hi,

In my project i have created a toolbelt wich allow player to use item by pressing number key, but the gameplay debug tool seem to override thoses keys. I have tried all solutions on this link, but no one has solved my problem. I got this problem on first and third person blank project on viewport, standalone and cooked game with unreal engine 4.11.

Are you using the function keys (F1, F2, F3 etc…)? if not, are the debugs views tied to the number keys? Are you seeing the pins being executed during run time? Is Input enabled in said BP?

F1, F2 to F12 keys seem to work here a image with broken keys

Pins seem to not be executed, and like i have said, i have tested all solution on the link from my firt post, so yes input is enable and all other keys works.

Any ideas ?

Have you tried action mapping the keys?

Yes, those keys are still blocked, and i’m still trying to found a solution.

Come on, no one got this problem ?

Hey Guiges,

I have a workaround that may be viable depending on your needs. If nothing else it should get you started in the correct direction. I warn you, it’s not pretty.

Example:

In this example I use the AnyKey event to read off what buttons are being pressed. From there I take the last character in the text (which in the number) and I use this to call a switch on int. From there I can have it call whatever events are needed to happen when the button in pressed. I hope that this helps.

Minor Note: I messed up on the screen shot, you will notice that the top print string says item 9. This was supposed to be a 0. Copy paste error.

Make it a great day

to use keyboard numbers…don’t use “1 event” …u shoold use “num 1 event” like picture show…it will work fine with numbers of keyboard Sanstitre.png