Number keybind does not work


I tried to set my custom kebind in Project Settings > Input to number “9” and it does not work. It works if I try some other key like “Q”.

Do you know where can be problem, please ? :slight_smile:

I find reason. It is because I use Slovak keyboard layout, EN works ok. I am wondering if this will be issue in final game because then it will be relevant to fix…

The problems is probably just this:

Each number appears twice in the list of input bindings: first as ‘0’, ‘1’ and so on, which correspond only to the standard keyboard numerals (those below your F-keys), then the ‘Num 0’, ‘Num 1’ and so on, corresponding to the extended keyboards numpad to your right. Also, there’s the matter of the NumLock key.

Yes I know that, I set “8” and was testing it with 8 key under F-keys. It is caused by language of keyboard layout. I hope It will not be issue in final game.

If your keyboard layout doesn’t work with numlock and numpad keys, you can rebind keys here:
Project Settings > Engine > Gameplay Debugger