Download

Nothing in the content library?

Hy everybody!
So tried to get in on some of the education materials, but it appears to be nothing here, what might be the problem?

Try a different browser. I’ve had content in lessons not show up or play after updating Firefox and when using Edge. Have you clicked any of the categories above? or tried going from Dashboard at the left and return to the content library?

Yeah, i tried everything. Wrote to support too hopefully they reply.
Also i get this too if i click around a bit

Even with mobile net.

That’s really weird. It’s working in Firefox 81.0.1 on my computer. It could be a server problem, or perhaps an obscure Internet option in the browsers.

Hi, Thanks for the heads up. I’m sorry you’re experiencing these errors. We are not experiencing or seeing what you’ve described here. Are you still experiencing it? If so, can you please submit a support ticket to UOLSupport@epicgames.com and we’ll get right on it.

Thanks,

Chris

Thanks Chris!
I wrote to them, we’ll see what happens.

Are you still experiencing it?

Chris

No, they refreshed my account, it’s all good now.
Thanks for the help!