Download

Not sure if I'm importing Rifle 01 Pro Mocap Pack correctly or not

So basically I bought this animation pack, which has about 700+ animations. When I try to upload it it gives me an error that says, “The following bones are missing from the bind pose:” Then it has a list of hand and foot bones, and then says “This can happen for bones that are not vert weighted. If they are not in the correct orientation after importing, please set the “Use T0 as ref pose” option or add them to the bind pose and reimport the skeletal mesh”.

I have no idea what that means. I tried selecting import all for the animations and then selecting “Use T0 as reference pose” and it takes literally 6 hours to import all these animations. That can’t be right. I also tried hitting import all, letting it give me that error, and then hitting cancel when it gave me the import options again, and they just showed up and seemed to work in my project. I’m not sure if it’s worth mentioning, but I did this in another project, tried adding a weapon socket and weapon to an AI character, and then suddenly the project wouldn’t auto posses my third person character (who wasn’t using any special animations or sockets) no matter what I did. I had to use the posses option on the menu bar. And then when I did that, some of the AI blueprints weren’t working correctly. So something got seriously screwed up and I’m not sure what. 6 hours of import time seems odd, but I just want to do whatever I’m supposed to do. I’m not sure what skeleton I’m supposed to use when importing it and whether or not I should check the “use T0A as reference pose” when importing them, and if the error message is important. Here’s a few screenshots to illustrate what I’m talking about. Any help would be greatly appreciated.

Untitled.png

Untitled3.png

It comes with its own skeletons, but tick the TOAs Ref pose option, as suggested. Double click each imported mesh and the side panel offers the TOAs option as well, then use Mesh Reinmport from the top menu.

Cool thanks, I guess thats how I’ll import them then.