Not reading alpha from texture with black or white colors only


I am trying to create a UI Material. It should read the alpha of the image to opacity, and then a Vec3 color as the color of the visible area.

I have some masked textures that only are of black color in the unmasked area.
When using this, nothing is masked, and the Vec3 col is shown as a square.
However if i recolor the texture to be not fully black, it reads the alpha as it should.
The same happens with a masked purewhite texture.

If i insert these textures into a widget image, same thins happen. A full colores swuare is shown


Left button is of a masked very dark grey texture.
Right button is of a masked black texture.

This is rather annoying as i cant import images from sites like flaticon, but have to repaint all of them.

Is this an import issue, or what might be causing this?

Tried to compare it with an altered version. The formats are different as the working versions are DXT5. So it somehow imports wrong, as i doeans’t change anything.

And it says “Alpha Channel: False” even though it has in other programs.

Tried, doesn’t help.

Show settings of your texture
Or attach the texture if you can

Untick sRGB and report back.

These textures have no info in the RGB channels and UE doesn’t like that. Even windows doesn’t like that. The icon on the left is of a converted texture. On the right is the original. I would suggest to just use bulk convert tool.


I’ll do someting to change the colors in general. Thank you a lot :slight_smile: