Download

Not all of the map has collision

Started a new map (new to this editor for the record) and I hoping one of you fine fellows can help.

Using sublevels (edit to add: Level steaming with World Comp checked in World Settings) I created the following landscape in a sub level.
map2.png

I set the collision to Ground as required.

Upon loading up the map (in play test or as a map in game) I found that only a small portion of the landscape has walkable collision. Upon walking past the indicated area the player falls through the map until Kill Z takes effect.
eaaaff98ed133b093206ea98e0d2bb46cc0bf3e4.png

Keep in mind this is with NO land sculpting of any kind and minimal painting.

What am I doing wrong here?? Is there some kind of setting for playable area that I have not found yet?

Thanks!

Tracked the problem to Enable World Composition. Moved the landscape to Persistent Level, with world comp on the problem occurs, with it off it mysteriously vanishes. Any idea as to why?

world composition is not supported by the ark dev kit and should not be used.

You do not need world composition to enable sub levels by the way :slight_smile:

Edit : was wrong about my statement, when i said world composition is not supported i refered wrongly to the fact that you cannot use the world composition for the tiling worlds with multiple heightmaps.

Watching tutorials said to check it on. Figures! Thanks Distov. I appreciate the feedback. Back to the map!

Would love to see some screenshots soon ! :slight_smile:

World composition needs to be ticked for sublevels to load (with streaming), This is only for streaming though, so you can have sublevels without streaming

This was my understanding too actually. Pretty sure World Comp has to be on for streaming purposes (which is a must for anyone doing a map the same or bigger size than TheIsland).

As for your problem OP; once you have all your landscape submaps done, it shouldn’t have this problem.

Or are you saying that your landscape submap even has this problem (aka just one submap added with landscape and collision only working for part of it?)?

@Ditsov Screenshots - You got it! Soon as I have more than just an empty boring level lol.

@sinarisinestro - The problem is consistent on submaps. Basically like this…

Landscape on Persistent Level:
World comp on - problem
World comp off - all good

Landscape on Sublevel:
World comp on - problem
World comp off - problem

Wow just do not understand why it’s doing it. I’ve been dealing with it for almost a week now. Just yesterday is when I figured out the problem with world comp.

Just for added measure I verified all files, and even redownloaded the whole thing again. (Using the Epic Games Launcher). Maybe that is the problem? EGL?

Which version the ADK are you using?

@uzumi18 - ADK version 201.6

Just a quick update - no progress on fixing this problem (bug?). I’ve resorted to redownloading AGAIN. I was hoping they would have updated the ADK by now and maybe addressed this. I’ll remain hopeful. However, if this new install does not work I am afraid my progress has to stop until a solution can be found. I’ve tried everything I could think of to get this to work…

Just to be clear, the problem is with level streaming - landscape on a sub level. Having world comp checked on or off does not help. The problem is there no matte what. If landscape is on Persistent Level the problem is gone IF world comp is not checked.

I’m having the same issue Waarden.

Will contact the devs about it :slight_smile:

Fix :

Disable world origin rebasing.

Thanks Ditsov! That did the trick. I’d had all but given up. Thanks much for getting a fix for this.

Edit to add: The setting is located in the drop down below Enable World Comp in World Settings

Well i started using sublevels for my landscape and that’s why i stumbled upon the same issue.

Then i remembered that back in july i had the same issue, and i remember unchecking something about world composition (that’s why in my first comment i said world composition was not supported by the dev kit).

It was in fact world origin rebasing.

Glad we can finally move on with our maps ! :slight_smile:

THANK YOU!!! This was totally killing my map progression.

Ive exacly the same problem, since 2 weeks. Disable world origin rebasing dont fixed it :frowning: