Not able to trigger the actor sequence with the keyboard

Hello friends!

In this document, at the end it is mentioned how we can trigger the actor sequence with the keyboard. I built all the components exactly like on the last image, but nothing happens when I click simulation or play, the key doesn’t trigger anything.

Is there something specific I have to take care of? I am beginner. Any help very appreciated.

I noticed that there could be an easily confused error when connecting the “Enable Input” node. Make sure you didn’t make this mistake:

Hope this helps!

Thank you, not really. I finally noticed it actually works, but only one, random instance. When I press the key, it triggers the sequence only on one instance, but all the other instances stay dead. And that is not what I need. I need it to press the key and it triggers all the sequences in instances at the same time, which would be expected. How is it not working? When I tell it to autoplay, it starts all the sequences, but I want to be able to start the sequences on all instances with the key, that is why I am using the actor sequence in the first place. Thanks for help.

Okay, I found it!!

In your Actor Blueprint, select the key event. Then, in the details menu, set “Consume Input” to false. The “Consume Input” option is what makes it so only one actor gets the event!


Hope this actually helps!

1 Like

Oh yes! That is the thing!! Thank you tons!

Sorry for my noobeness, but how come the keyboard event doesn’t work in the simulation/play while in the blueprint window and it only works when I hit play in the level? It is obvious I have to read some documentation here, but not sure where to start. Thanx :slight_smile:

I think it has to do with the fact that the PlayerController isn’t possessing your pawn in Simulate mode, but it does possess the pawn in Play mode. That is probably the reason why the input isn’t working in that case.

Difference between Play and Simulate