Not able to correctly set icon and name for packaged game

I have followed all the steps while packaging a game. I have tried all steps listed in Unreals packaging docs. I have added the right ico files and have named the game correctly in my Project Settings.

I get the game icon properly in the file browser (image 1).
The game icon is wrong in the taskbar (image 2).
In the Task Manager, it says Unreal Engine (image 3).
When I expand the app running in the Task Manager, then I see the correct name as you can see in the following images.


136072-136073-

Hello adarshmuthappa,

I was able to reproduce this issue on our end. I have written up a report and I have submitted to the developers for further consideration. I have also provided a link to the public tracker. Feel free to use the provided link for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-36945)

Make it a great day

When can I expect this to be resolved? This is crucial for our release happening later this month. Are there any workarounds? Could you direct me to specific code so I can perhaps fix this locally while I wait for a fix in a future release? It seems Raw Data has been able to work around it :P.
Thanks in advance for your help.

I addressed the issues you are describing in 2 PRs which are currently still awaiting review by Epic ( https://github.com/EpicGames/UnrealEngine/pull/2840 and https://github.com/EpicGames/UnrealEngine/pull/2799 ). Let me know if they resolve your issues for you :slight_smile: .

Hey project.ghesit,
I ran your code and it fixed both issues for me. Now, the icon and process names are correct. Hope this is added to the Engine ASAP. Thanks a ton!

Both of these changes got pulled into the Engine and should hopefully make their appearance in 4.14 :wink:

It appears to still be an issue on Unreal 4.14.1 with Windows 10 Pro

(FYI - I have not tried the custom icon just the .exe name)

118112-taskmanager.png

It was a misunderstanding from my part. The icon change got checked into 4.14 and the exe name change is going to be in 4.15.

Hi,
I read that the icon problem should be fixed in UE 4.14. We use 4.14. but unfortunately we still have exact same problem.
The icon is displayed correctly in the task manager and on the desktop, but is not in the task bar.

Can you give any insights in how you fixed the problem last time?

Hello VNDERS,

If you are still experiencing this issue, could you provide a detailed list of steps to reproduce this issue in a clean project? Also, are you using windows 10?

Hey,
we still have the error, but we managed to find out that the icon in the task menu is correct if you start the game with log.

It also shows the icon in the task manager, but the child task also does not show the icon.

128858-2017-03-06+19_08_17-task-manager.png

In order to assist you further I will need to to provided answers to the questions I asked in my previous post.

To note: The EXE name is still broken in packaged games on Windows 10. It’s working fine on Windows 7 though.

This thread deals with the icon that is used. I would suggest taking a look at the thread provided below for more information on the issue that you are having.

Link: Package game name - Programming & Scripting - Unreal Engine Forums

Is there an issue specific to the incorrect name or just the one that was setup for the icon?
My packaged game shows UE4Game with a sub process having the correct executable name. This is in 4.16.2. If it doesn’t have an issue assigned please let me know and I’ll submit a question for it.

http://i.imgur.com/n86bEJo.png

So I was getting this issue (4.14) and figured out the repro. When UAT (or Unreal Frontend) builds the game it messes this up. My workaround was to have the target built before I ran UAT to package the game. So UAT just copies the built exe over instead of making a new one that has this issue (where the Icon shows up in the root process but not the sub process which is what is displayed on the task bar).

I’m still having this problem in 4.21 but my workaround was to open the compiled executables in Visual studio and edit the details there. You have to redo the process with each new build, but it’s better than the alternative.

@hejden please can you give steps, what details and how should we edit in visual Studio…
Thanks in advance

  1. Start up Visual studio.
  2. Go to the “File” menu and choose “Open” and then “File…”
  3. Select the executable you want to edit the description for.
  4. When the file opens you will see a list of folders. Double click the “Version” folder.
  5. In the Version folder is a list of localized version information. Or just one if you only support one language.
  6. Double click the language you want to change.
  7. You’ll see a list of fields that you can edit. For example “FileDescription” or “ProductName”. Fill out the fields to your liking and then save.
  8. Select the executable in the File Explorer in Windows and click “Properties”.
  9. Click the “Details” tab to check that the values have changed properly.
  10. Run the executable and then start the Windows Task Manager to make sure it is listed correctly.

Remember that there are two executables in your build folder and both needs to be edited. One is located in the root folder and the other in the “YourProjectName/Binaries/Win64” folder. If you build for more than one platform (Win32 for example) there will be more than two binaries.

But my advice is to try and solve this in whatever way Epic intended first and only use my solution if all else fails.