[NOT A BUG] upload sketchfab resets reconstruction region

I manually define reconstruction region, do not let it simplify model for sketchfab (since I know that resets the region)
then upload to sketchfab via api key and the old far too large region is restored, and filled with edge colours.
Example model https://sketchfab.com/models/a8aeeaa1b0 … 2be87958aa
Before upload, the reconstruction region was set to inside the tray borders.

ok maybe it’s something more complex that just the reconstruction box being reset…
manual export of the model also gives me the larger solid… and afterward the bounding box on the model is displayed as large again. But I’ve also defined the ground plane this time… but the generated reconstruction projects far below the ground (but the manual version sits above it).
I’m not sure whats going on but the large block under and around my model isn’t supposed to be there!

ok, so it’s something more complex or confusing than that…
This one correctly loaded even after smoothing and simplify tools
https://sketchfab.com/models/8cbfbe8687 … 9c25550cce

Only difference I can remember is this time I exported the reconstruction region before I ran the tools (so I could just reload it if something got confused). Perhaps the region this time was interior to the tray, when past attempts had it near but not inside?
Clutching at straws…
Thank you
(yes that is a mining/geology core tray… usually we only take one picture but I got a the guys to take a couple extra so we could try modelling it)

Hi Jennifer Cross

After you set the REconstructionRegion aka BBox, you need actually use the FILTERING tool to make changes to the model. If you not use FILTERING tool then all model parts stay there as nothing was applied. down in the FILTERING tool is button APPLY…

Hello Jennifer,

creating recon box when your model is already calculated doesn’t change geometry. Even clipping box doesn’t change it (clipping box is used just to hide unwanted geometry in scene). As wishgranter already said - you have to use filtering tool to actually remove geometry.

ok that is even more confusing…
I have been using the reconstruction box to limit the water tight model edge/bottom.
But then it wasn’t clipping it leaving with the weird block thing
And then it did… (no filter - but I did apply smoothing and simplify with the bbox in place)
for the final one that worked, this was the bbox that survived all the operations (previous attempts, the bbox was bigger after upload/save than before) I haven’t used filter because I couldn’t find a way to draw a (selection) box…