Normals don´t work since 4.4

Hello everyone!

I ran into a problem earlier today, after updating to 4.4.

I have this model which I already managed to import corectly into UE 4.1, to be specific I got all the settings right for baking Normal Maps so one can´t see any seams. (Correct FBX format setting + XNormals with flipped Y)

The very same reimported model, texture and material happens to have quite severe seam issues in 4.4.

Does anybody else experience similar issues?

Thanks in advance!


Hey PeterKay -

I have been trying to test this out for you but haven’t had any success in reproducing the issue using Maya and XNormal. Would it be possible to get your Normal Map and FBX, or one that also exhibits the same error for you, so that we might test it in house?

Regardless, I am continuing to look into this for you -

Eric Ketchum

Wow, thanks! Is there a way I could send you the model and the Normal Map on a private way or would that be too much trouble?

Feel free to private message me through the Unreal Forums.

Eric Ketchum

Hey PeterKay -

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Eric Ketchum

Hey PeterKay -

I found the issue. If you open your normal map’s texture in the editor make sure that the Compression setting is set to TC_Normal and not TC_Default, then in your Material, make sure your Normal’s Texture Sample node has its Sampler Type set to Normal and not Color.

This immediately solved the problem when I changed it in my editor.

Thank You

Eric Ketchum