Download

Normal map slightly offset in UE4, looks fine in Blender

Hello, I’m very new, just finished up my first ever model following the popular Blender Guru’s Anvil series. Figured I need an anvil for my game so may as well, but that’s unrelated.

Here’s my issue: the normal map is offset slightly, but only in UE4. I have screenshots of both normals as seen in UE4 and Blender, they are relatively the same but I “flipped the green” something or other in UE4. I really have no idea what is causing this so here I am. Thanks for the help in advance, I’ll be actively watching this post for the next few hours.

have you tried flipping the green channel back? looks to me like its the wrong way
Edit: is it set to the right compression as well?
Edit:Edit: def looks like its running the wrong compression, maybe on a lower mipmap

Explain compression to me, I don’t know what that is or where I can set it.

Edit: I see some options but none of them seem to have the desired effect… I have only worked in Blender and this is the first time I’ve put something in UE4.

Look into your Static Mesh and turn on UV Channel 0 and compare it with the UVs within Blender

I think this is along the lines of what I need, UV level 0 doesn’t match up at all to Blender, but UV Channel 2 does. I just don’t know how to SET the channel, only overlay it. I don’t even know why there’s multiple UVs.

I went into Blender, figured out there were 2 UVs in the mesh for some reason, and UE4 was using the first one while Blender was using the second one. I just deleted the first one and reimported, voila!

Thanks for the lead, Raildex_.