Download

Normal Map Shading Problem

Hello dear unreal artists! I’m confused and i need your advice. I have a very unusual shading problem with my normal map - it looks totally fine in areas affected by direct lights but all the bounced light and shadow areas have this weird inverted red channel effect.

Here is the small list of things i already checked but none of them really helped me to figure out the cause of this weird shading glitch.

  • Proper DirectX normal map file;
  • No UV mapping errors, mirroring or complex UV map transformations;
  • No errors in material editor’s preview;
  • No shading artifacts in Lighting Only or World Normal display modes;

Can anyone please tell me what is happening and why. Thanks in advance.

​​

It doesn’t look inverted to me

It isn’t actually, World Normal buffer shows no inversion.
Probably not the best way to describe the effect i would like to get rid of, but to me it just looks somewhat similar to red channel being flipped in shadow areas. In general, all i want to do is to make those grout lines look nice and straight. What i have now is ruined by this nasty inversion offset.

I’m saying there’s nothing wrong, it’s jut how the shading looks, the shading is accurate

It is the light, the fall off is too short.

Ok. Is there a way to make it look like this? That is the shading i want.

It is a very simple lighting setup - one distant light plus one sky light, so there is no actual falloff distance to manage. Yes, i’m pretty sure i did something wrong in my lighting or GI settings, still keep trying to figure out what exactly can be the reason of this effect. Thanks for the suggestion!

You could try rotating the skylight’s cubemap or turning off the skylight’s cast shadows option.

Are you using a 2 sided material, that can screw up the normal map’s directionality? …is there any AO in the scene (in your material or postprocess/lightmass settings?

Already tried that along with using different GI intensity values. Same thing.

No two-sided materials here, disabling AO/SSAO just slightly decreases the effect, but it stays “flipped” in shadows anyway.

It’s likely just the ambient lighting having some directionality. Try different lighting scenarios and see if it is consistent.

Does the project use High Precision Normals for GBuffer Format (in project settings in Rendering)? And for the model, are “High Precision Tangent Basis” and “Full Precision UVs” enabled? If not, try enabling those. Those give better, more accurate results for lots of things with normals, such as reflections and flat panel floors.

It looks like there is another less bright light causing shadows to the other side outside of the bright light’s light cone. It could just be the (ambient) lighting from the skylight if it has an HDRI in it. I also don’t think there is anything wrong with it.

I did try quite a lot of those scenarios, including the simpliest one - no skylight, one directional light with default intensity and one bounce. Same thing.

It didn’t work in my case, but thanks o lot for letting me know about these options, they seem to be pretty important features to be aware of.

Yes, that was one of my first suggestions - environment light is somehow overlapping/conflicting the key light causing this weird shading effect. Turned out that wasn’t the cause.
P.S. I just checked out your website! Wow! Your archviz projects are totally amazing!

I wish to thank all of you for your attention, advices and suggestions. Looks like i’ll have to go with this type of shading. I will post some updates if i manage to make it look the way i want. Thank you very much!