Download

Normal Map is "smudging" or "blurring" the texture, how to fix? UE4.25

I have attached a picture to show what’s going on. I’m not sure where the error is. I’ve been making a low poly of a truck I got off Sketchup Warehouse. The low polys have proper UV mapping and have high poly meshes baked on the low poly.

I should also mention that when I view the actor inside the actor Blueprint’s viewport, it looks fine.

i think its the mesh normals and not the normal map that is causing an issue with one of the screen space effects. try reimporting the model with compute normals enabled

Thanks for the reply! Compute Weighted Normals was already enabled when I imported my meshes. I tried all three Normal Import Methods, tried turning off the Compute, tried both Normal Generation methods and probably every combination of them. No effect, even turning off Compute gives us the same result.

if its ok in the blueprint viewport then it must be from the postprocess actor in your level. try disabling that first and then try disabling each effect separately and see if you can pinpoint the one that is causing the issue

I’m running this in Unreal Engine’s vehicle template and I don’t think I see any post process actors. I also tried to migrate my actor to the project I’m working on, which also doesn’t have any post process and contains actors that I have created in the past with the exact same methods. The actor’s smudging problem doesn’t appear in there but now I have a new problem. An awful glare on the entire body!

have you set up your material properly with specular and roughness maps?
is your base color texture srgb enabled?
are other maps like spec and roughness srgb disabled?

1 Like

I fixed it eventually by having to remove the normal map and bring the metallic down to zero and increased the roughness by 3 times. It looks “okay” now I guess.

Just to update a possible solution to this, I was making materials for another model and it happened again. I was able to find the culprit, which was the DEFAULT NORMAL MAP which is normally applied to the texture parameter in the base material. For some reason, when an instance is created, and another normal map is put in it’s place, it goes b@tshit. Simply replacing the default pebble thing normal map with any other custom normal map in the base material fixed up my model.
this_warty_fuck_was_the_culprit