Download

Noob... Trying to add my first texture, issue?

I was following a tutorial on YouTube… It got to the bit were I found simple floor texture, added it to my project , then dragged it onto a block.

The image appeared on the block but was huge…

https://live.staticflickr.com/65535/51399211994_7c7f739185_b.jpg

I need to ‘multiply’ it apparently. So I double clicked the mat file, in there right clicked to add a multiply and dragged the noodle to the UVs on the Texture Sample.

The moment I did that, the texture disappeared.

https://live.staticflickr.com/65535/51398728383_9ef290e340_b.jpg

On the left under Material Expression Multiply, It was defaulted to

Const A : 0,0
Const B : 1,0

I tried a range of values in these too inputs… Nothing changed.

This is my first play with textures. So this is a super noob question. I know that. But if I can get help with this I can get on with the tutorial…

I’m no expert on textures, but I’m pretty decent in math. You’re multiplying by zero, which always results in zero.

As you have it set up in the pic, you don’t need a multiply there at all. I think what you’re looking for is a texcoord node, or something like that.

Good luck.

This might help:

Lord_Volkner

By default the multiply comes in with
Const A : 0.0
Const B : 1.0

As a qualified noob having his very first look at UE4 I assumed one value could be 0…

I tried the values 1.0 and 1.0

https://live.staticflickr.com/65535/51399996112_4bb06bdd80_b.jpg

Clearly I am missing something here… I am really keen to just get on with the tutorial. But I’ll have a look at the link you shared. Thanks

5 seconds on that page you linked and I worked it out.

I need a TexCoord and not a Multiply.