Download

Noob stuff: landscape blend paint resolution

Hi all,

Im a nub trying to create his first level. Man this level design stuff is tough.

Anyways, Ive created a landscape and a blend material to paint textures. Thing is they always look blocky (see screenshot).

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-tempid”:“temp_116920_1505273397557_310”}[/ATTACH]

Here’s my material :

I made many research on the web and on this forum. Here’s what Ive tried :

  • Deleting and recreating landscape (no change).
  • Converting Height Blend to Weight Blend (seemed to make it a little less blocky, but still blocky).
  • Change landscape component size (makes blocks smaller it seems, but still blocky).
  • Creating a bigger landscape (no change because quad density seems to stay the same).

So is there a way to completely remove blocks???

After using the flat sculpt tool and visualizing in wireframe, looks more like a landscape mesh resolution thing, not sure. But I’m guessing it’s the same for everyone, so still don’t get why my painting looks so blocky.

Honestly to me it looks like your texture resolution is low, causing a block look. “I’ve had this issue once before”.

I download Substance Base Textures, as with substance textures you also get a config file where you can open
the file and change the resolution and settings of all the texture properties.

Then for tiling setup, use the coding “Blueprints”…from the StarterContent Grass, and copy it over to yours and
change the textures in it to yours, and it will tiles nicely and look ten times better.

I’m not advertising or endorsing the website I provided, but use there services to obtain my textures.
Sorry, as it is not a free site, but does have some free textures to test my idea for your problem.

Website I go to…

Try what I was talking about, with using a Substance texture File instead, as with in the RED Config file they provide, it will allow you to change
resolutions form 128 all the way to 2048 easy with just a click. Might get a result you want.
Could be a weightmap issue.

I found this link, maybe some insight to the issue you have. or options to help.

but every time I have dealt with Block textures like your pic had to do with the setup of the file in the blueprint.
So I switched to a substance file and haven’t had issues since. some reason it went away with the setup I used.

Here is a link to the plug-in installer.

VICTORY!!!

Finally I figured it out, my observations were correct! Here’s what I did:

I noticed in the extracted landscape texture from ExampleContents that there was a detailed alpha channel that basically was a black and white version of the texture blended with a noise pattern. Therefore, I replicated the same, I created a black and white high contrast version of my texture and a seamless noise pattern on another layer and blended them together. I merged the layers and copied the result as a new channel. After this, I made sure my original colored texture was visible in my layers and I flattened my layers then saved it as a PSD.

I reimported the new versions of my texture and once updated the “blockyness” dissapeared. The only thing is that just like jakehowe2004’s first solution, falloff no longer has any effect on my brush, but the transition looks awesome as is so its not even necessary.

I dont know much about materials yet, but I’m guessing the fact that the texture’s alphas connected to the Layerblend’s height nodes has something to do with the result. It seems to make the alpha channel “control” the appereance of painting.

Now my paint looks awesome on a low resolution landscape mesh. You can view the screenshots of the Photoshop alpha, the material nodes and the painting results by clicking on the images below.

That being said, hopes this helps others. Thanks again to jakehowe2004 and others who helped. :slight_smile: