Noob: Shaders compiling everytime I open project

Hello all,

I am a complete noob to Unreal just started doing a Udemy course with it, but, I seem to be running into issues that no others people in the course are running into. We are making our time just basically using the Terminal "actor and I saw that everytime I opened the project the shaders needed to compile - everytime! And as I started to make changed to the project the number of shaders started to increase, I added in a couple of items from a free asset that I found and the shaders went to over 2k, and while these shaders are compiling I can’t do anything, I can look at code and make changes but I can’t compile it till the shaders are finished compiling “again”.

Is there anything I can do as a noob to speed up the process? Or is this something that is part of the Unreal development process that I am going to have to live with?

alternate path

Thankyou for replying it is appreciated. However I am not sure what you mean by alternate path. I ran a google search on the term, but, did not yield any results on Unreal shaders.

Could you please explain what you mean to a noob level user?

Regards.

Ok, would someone here be able to explain what this means and what it would entail to stop the over 2.3k shaders from always compiling when I open up Unreal.

I really would like a solution before delving further into game development.

Thankyou and Regards.

Thankyou for all the support in getting my Unreal projects working correctly it is very much appreciated.

The people of this forum should be congratulated for helping this noob taking my first steps in Unreal.

Thankyou greatly.

I’m not sure what is happening, but I encountered it early in using Unreal Engine a year or two ago. There might be something in the project settings or preferences that is initializing the shader compiling every time. It shouldn’t be doing that. Try doing a search in Youtube on it, like typing ‘shader compiling when opening Unreal Engine 4’, or ‘how to prevent shader compiling at UE4 start’…

I don’t remember how I solved it, otherwise I’d write that.

Sorry for the lateness of my reply. Been extremely busy since I wrote my initial question, and then the browser that I was using to access this site just crashed and refused to work and after a while plain forgot. It’s only since I installed Opera that I have been able to get access to this site. FireFox stopped and couldn’t upgrade, then Chrome stopped working and couldn’t upgrade, then another browser that wouldn’t work at all, versioning software, video editing software, it’s been fun.

Anyway, thanks for taking the time to respond I did find out what the issue was and required a new computer to get it working something about the partitions and permissions being set wrong. Just finished getting that setup. That issue cased so many program to not work correctly or work at all. Like the browsers I just mentioned. Now with the new system Unreal is working a real treat compilation times that used to take 10 mins are now down to mere seconds.

Regards,
Vaughan.

1 Like