[noob] Adjusting snap for scaling tool

I’m trying to make a indoor level. In order to build walls I used the basic box in the geometry panel and shrunk the depth, and enlarged both the height and width to the size of need. The problem being when I scale up the snapping amounts for the scale is way too high. I tried adjusting the snapping size like I would in for the translation and it has no effect on the scale tool. This is causing my walls to be slightly bigger then the height needed between the floor and ceiling for example. This is not visible from within the game but from the editor it looks horrible if you are outside the map.

On a related note is it possible for enter a number I want for the size of a object? For example if I know I want a room to have walls that are 3 meters high(9 feet or 3 UE units), 9 meters long(27 feet or 9 UE units) and 1 meter thick(3 feet or 1 UE unit) can I put those numbers some where and have it make a box of those sizes?

Thanks for your help.

PS. Yes I know the exact conversion between meters to feet is not 3:1 but its close enough for these figures.
PSS. Mostly I am working with in the editor and with blueprints but I also know C/C++ if that makes it easier to do this stuff but I don’t see how that would be.

You could just adjust this difference with the “edit mode” from the geometry -> select the vertices and then you can move it

Same for me while adjusting the collision boxes. Scaling is going too big or small once I move the cursor. All of my snapping settings are off, as far as I know. However, its still happening. If anyone has a solution, that would great.