Non texture sphere shows on game start

While creating this pinball game, where I am almost done everything. Everything was running smoothly, but now when I placed the outside Table mesh I started to have the following issue

  1. Ghostly Grey Ball : This random non - textured ball appears out of nowhere
    The non texture ball has controls WASD (moves on XY axis) and QE (moves on Z axis). But, my inputs are on “Left, Right, Top, Down arrows && Num 1 & 2” only. No bindings on WASD & QE.

Previously it was all running smooth, since the last checkpoint its all misbehaving.

Sorry, I am kinda new to UE.
Answer to your question : I am just clicking the default “PLAY” button next to “LAUNCH” from the toolbar.

Running the game on “Selected Viewport” spawns the ball. Whereas running the game on “Simulate” does not.

are you playing in simulate? i believe playing in simulate spawns this spectator actor thing, it might be that

in the play option you have a dropdown arrow, you can choose different options there. standard it shouldnt be on simulate i believe. Does this sphere also appear while playing on a packaged application?

interesting. i do believe its a unreal bug and it will never appear in a packaged project, but you should still test it. Is there a way for you to highlight it and see it in the scene explorer?

Finally, I got it fixed. Although, I do not have any Pawn in my entire setup. Somehow the “DefaultPawn” was selected in Project Menu > Maps and Modes.

Solution : Changed back to “None”. And it removed the ball from spawning on the scene.