Download

Noise in surface with raytracing

Hey all, I haven’t been able to get much love on the answerhub on this issue so wanted to check here.

I’m trying to render a camera shot with a dynamic shadow in the background but running into a lot of noise.

  1. I’m getting the noise in my surface reflection. There’s a dynamic light out a window bouncing in on the wall and the floor and the reflection off the wooden shelf is giving off some noise. Having a helluva time figuring out where I can fix that.

I have raytracing enabled, though I get less noisy results when I set the Post Process Volume’s >Reflection Type to Screen Space instead. Most of the noise goes away and I actually get a better image.

  1. Lastly, I’m having trouble getting decent, dynamic shadows from foliage cast from that directional light. The foliage, dynamic light, and skylight are all set to movable so not sure where that’s going wrong . The only shadows that are cast don’t appear to be moving in sync with the foliage, but instead are giving off a noisy flicker within it.

That’s it. Just stuck and hoping someone can set me straight.
Here’s a few pics of settings I have for items:

you should check out the archvis interiors project for a good idea on how to set up scenes

https://learn.unrealengine.com/cours…320?LPId=89346

I had followed this tutorial on the learning tab, I’ll have a look at this one as well thanks

It was UNreal Academy 2019’s Lighting and Materials Toward Photorealism lesson, in case that link doesn’t work

Okay, so I’ve got this project you recommended open, the Archviz Interior. I watched this video actually, very amazing stuff.
However, I’ve not touched a single setting and I STILL have this noise in the reflections…
I just took a short clip of one section, it’s on the surface of the wood bookshelf, and it’s in pretty much in most light reflected areas

have you tried the high quality rendered one?

Thank you, my luck seemed to be by following a different tutorial and long story short just entering different settings in the World Settings and the details panel for all the lights. Can’t explain it, but whatever combination I had (as seen in the screenshots I added) made that happen.
Instead I followed this tutorial series, which has a diff approach to the original Epic tutorial from 2019:https://youtube.com/watch?v=dQ8bqHUg5ToThe guy’s name is Ryan Manning, was very helpful