No Windows Explorer Context Menu


I’m using only the source version of the engine, not the binary version through the downloader. I miss the useful context menu when right clicking on uprojects in windows explorer, used to generate project files mostly. It worked just fine in the beta days, and I know it’s still supposed to work, but it’s not for me. When I run UnrealVersionSelector-Win64-Shipping.exe after compiling the engine, I get “Registration successful”, but I’m still not getting anything when right clicking on uprojects and the launcher doesn’t recognize that I have the compiled source version. Any and all help is appreciated!

I’m using 4.2 now, so the batch file for registering extensions is obsolete. I had the same issues with 4.1, could never get it to work.

Hi ,

How current is your source version?

Hi ,

Sorry for the delay in getting back to you. Just to make sure we are looking in the right place for a solution, can you confirm that these are the options that you are looking for?


Yup, that’s them.

Hi ,

I am going to do some digging to find out why those options are not appearing for you. I did want to try to clarify something for you, though.

I don’t know if you are aware of this or not, but the Launcher will only install and launch binary versions of the Editor. You won’t be able to use the Launcher to run an Editor compiled from source code. To launch an Editor compiled from source, you will have to run the executable that was created when you compiled it.

Hey -

Couple of possibilities I thought of:

  • Try right clicking on a project file, selecting ‘Open With…’ and ‘Choose default program…’, then make sure that ‘Unreal Engine’ is set as the default.

  • If that doesn’t work, we had a bug a while back that would setup the file associations on a per-user basis and take precedent over the per-machine settings. You might have a bad setting there which is overriding the defaults. Try going to a command prompt and running:

    reg delete HKCU\Software\Classes.uproject

1 Like

I apologize for the late response. When I run the reg delete command, I get “ERROR: The system was unable to find the specified registry key or value.” I assume that means that the registry bug isn’t what’s causing the issue.

Should the default program should be set to the launcher exe (UnrealEngineLauncher.exe), the version selector (UnrealVersionSelector.exe), or the compiled UE4Editor exe file in the source binaries?

I’m aware of that, and I have no issues running the editor. I only want to be able to have access to the windows explorer menu when right-clicking on project files.

It should be going through UnrealVersionSelector. I’m quite puzzled as to what could be happening. Could you run these commands from a command line to export bits of your registry, then post the info1.txt, info2.txt and info3.txt files it generates back so I can take a look?

reg export HKCR\.uproject info1.txt
reg export HKCR\Unreal.ProjectFile info2.txt
reg export HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.uproject\UserChoice info3.txt

Just upgraded to 4.2.1, and now everything is working. Something I did differently was to download the source code from the release page zip file ( rather than cloning the github repo. Don’t know if that’s what did it, but unless somehow 4.2.1 fixed the issue that’s all I can think it would be.

Hey there,

Just in case anyone comes back to this. I moved my installation folder so the context menu was not pointing to the correct path anymore. Using 's knowledge above I found out how to fix that.

How I fixed this

In cmd use the following commands.

*reg export HKCR\Unreal.ProjectFile temp.txt*

It will export a file called temp.txt to your current directory in cmd. Open it up and make sure your paths are correct to your unreal installation. Save it

*reg import temp.txt*

All done :slight_smile:


I’ve just found a super easy solution:

  1. Take UnrealVersionSelector.exe from Epic Games\Launcher\Engine\Binaries\Win64

  2. Copy it to Engine\Binaries\Win64

  3. Run and click Yes on prompt “Register this directory as an Unreal Engine installation?”

Voila, it should work.


This is ezpz solution, Thanks ZimaXXX

Amazing! Works perfectly. Thank you!

Best Solution - even better than the one accepted - thanks!!!

It might also be the windows version,or the fact that there are pending updates. I have that a lot that as soon as there are updates that were downloaded, things do not work anymore (especially media related (audio, video)) until I actually rebooted and installed the updates. I just installed a fresh early copy of windows 10 without updates and installed ue 4.20. Context menu options were missing and also some solutions on this thread were not working for me. I removed everything and downloaded the latest version of the epic launcher installer and after updating windows to the latest version and installing the epic launcher + ue 4.21 I have the context menu entries back.

Hi ,

I am running into problems selecting the correct UE engine version when I have multiple versions installed. In my case I am trying to use UE4 v4.17 and v4.19.2.

If I uninstall UE4 4.17, then my UE4 4.19 projects work fine. With only UE4 v4.19 installed I also tried copying the UnrealVersionSelector.exe file into the UE4 v4.19 engine/bin/win64 folder. When I did this I was able to see the right click context menu options:

  • Launch game
  • Generate Visual Studio Project Files
  • Switch Unreal Engine Version

When I reinstalled UE4 4.17 all my uproject files appear to be associated with UE4.17 rather than the correct version, which is 4.19.

Next, I tried running the three reg export commands you listed above. The first two worked and I am attaching the resulting output. The third command failed with the error message: “Error: the system was unable to find the specified registry key or value.”

Finally, I tried re-copying the file UnrealVersionSelector.exe from: C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64 to: C:\Program Files\Epic Games\UE_4.19\Engine\Binaries\Win64 and C:\Program Files\Epic Games\UE_4.17\Engine\Binaries\Win64. I then ran UnrealVersionSelector.exe from each of these destinations and answered “yes” to the prompt to register this directory as an Unreal Engine Installation. Unfortunately this did not correct the version association problem.

Can you help me resolve this situation?

link text
link text

hi @ZimaXXX,


i install unreal engine from Laucher, but this menu context not show in windows explorer

Hi, i got the same problem with 4.26 in Win10 64.
So i fixed that with this cmd file: (1.1 KB)

1.) Download, extract and open “UnrealProjectMenuRegistration.cmd” with notepad or another text editor.

2.) Goto Line 16 and make sure, your install path of unreal is correct. In my case it was:

HKLM\SOFTWARE\WOW6432Node\EpicGames\Unreal Engine

3.) Save it and run it as administrator.

So i dont need restart windows, but its not work - try restart and context menu should work.
Hope it helps! :slight_smile: