No way to move player with keyboard (solved)

WSAD dont work for player movement, tried with the 3rd person option from the 1st menu that pops up(Cube player), tried the shooter sample as well, both a no go, tried every button on my keyboard but nothing moves the player. only spacebar(and i think left ctrl) allow jumping.

the mouse pans the camera, my xbox360 controller does allow player movement though, iv reinstalled rocket 2 times and tried several projects.

I am using a razer deathstalker ultimate keyboard, possible issue? i dont have access to another keyboard, but using the on screen keyboard and clicking WSAD does in fact work.

EDIT: Iv found the issue, i had a piece of software my university gave me for my dyslexia issues that had taken over my keyboard pretty much.

I haven’t run across any issues with certain keyboards not working, but I also don’t have that particular one to check out. You said you don’t have access to another keyboard – perhaps a friend may let you borrow one for a couple minutes (I hope you have access to friends. ;)).

In the mean time, I’ll see about getting one of these in an attempt to reproduce your issue. Let me know if you can try out another one while we wait.


Iv tried with a Microsoft sidewinder x4 just now, still not working, very strange, im on windows 8 x64 professional, maybe its a win 8 issue?