No UE5 tab in Launcher

Apologies if this question has already been asked/answered but I’m trying to download UE5 via the launcher, however there doesn’t seem to be the pages that all of the tutorials show it is on.

When in the UE hub, the top menu bar only shows News, Learn, Marketplace, Library, Twinmotion.
Everywhere else I’ve seen it, there has been a ‘UE4’ and ‘UE5’ tab.

Please tell me there is some blindingly obvious mistake that I am making.

Chairs x


Simply go to “Unreal Engine” on the left , then on “Library” on the tob tabs and add the new Engine Version by clicking on the plus button directly at the top (above your installed unreal versions).
Select 5.0.0 preview 1


Having the same issue, no UE5 tab shown. I have it downloaded on my other pc and the UE5 tab was showing. Screenshot attached. Please help, this is driving me crazy!

UPDATE: Having the same issue and the plus button is greyed out, no new options.
I have reinstalled the launcher, made a new account, tried everything but it won’t give me the option.


Simply click in the arrow next to 4.26.0 where you can select which version to install


It worked! Thank you so much, I completely missed that arrow.

Nice to hear that. :slight_smile:

1 Like

This did not entirely work for me. My version of the launcher does not have the UE5/UE4 tabs, plus the dropdown next to 4.26 on the pic above was not there (4.27 in my case). Clicking the “+” next to engine versions did nothing for me.

This took a while to figure out, but the “top right” install button adds an engine version WITHOUT the “arrow dropdown”. Uninstall any unreal versions.

With an empty list of game versions, on the “Unreal Engine/Library” page, the “Engine Versions +” adds an engine version WITH the missing dropdown icon and can then select Unreal 5 from that dropdown.

1 Like

For reference, the UE5 tab itself was removed, and what was the UE4 tab has been renamed to News.

Thanks for the additional notes about the flow. I’m going to pass that along to our team.

1 Like

Hey that’s good and all, but how does that; in any way, help us to install unreal engine 5, that cannot find it on the launcher???

1 Like

it IS on the launcher like described above.
Furthermore you can compile it on your own.

OMG Thank you, I had the exact problem and your solution was the only one that worked. I removed every version and clicked the plus next to ENGINE VERSIONS, and my 4.27 version had a drop down menu with ue5 preview.

Thank you so much! That explanation resolved my issue.

1 Like

Thanx bro! Made my day!

I had to reinstall the epic games launcher to get 5.0 to show up in the library.

1 Like

It showed for me after the second reinstall.

a similar question… where is the learn tab?

Is suppose the old learning information can be found under “Samples”.
What are you searching for?

I can really not believe that so many people are currently having problems for finding stuff only because of these small changes in the launcher.

Futhermore there is a complete learning side on the web:

is it solved yet ? do I have to reinstall everything ?
why is it so cryptic


ok I found out I had to click on the [+] in the library tab