No transmission option for materials


In UDK i used Transmission for my two sided materials like trees, grass, etc that helped me to make the other side of my planes brighter and smoother. Now there is no such thing in materials, only subsurface scatterint that didn’t solved my problem so far. I know i could setup vertex normals and such, but i can’t do that at trees with 5000 vertexes. So any good idea how to solve this problem?

Hi Ashkandi,

Take a look at our Docs here referencing Translucent Shadow Color: CPU Lightmass Global Illumination in Unreal Engine | Unreal Engine 5.1 Documentation

This will explain how to use Transmission in the editor now since it does not have a material slot.

Thank you!


Thank you for the answer. Could you show me a basic material setup for a simple leaf plane with this Translucent Shadow Color? That description on the site how i should make it is not fully clear for me. : /

No problem. :slight_smile:

I thought I had included a link to a tutorial I did on the wiki for setting up transmission (with a stained glass window as an example), but apparently I didn’t. :confused:

so here’s the link: A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

This includes a sample project I made as well.

Here’s a leaf texture I grabbed off the vast interwebs and threw together real quick as an example along with the material setup and parameters that were changed to get the effect.

Key points to remember:

Only static lighting can cast shadows for transmission and Lightmap resolution of the object the colored shadow is being cast on will determine the quality of the colored translucent shadows.

Feel free to ask any questions if you get stuck. :slight_smile: