Download

No transform window for geometry brushes like boxes?

There is no transform window for geometry brushes like boxes. How can I get the transform window?

There is Geometry Editing section in Modes tab.

We currently don’t expose a transform type-in in the details panel (like with ‘normal’ actors) for geometry brushes. As far as I understand this is to do with the extra restrictions on brushes. For example they can only be manipulated in world space and cannot be parented to other actors.

I have just ran into this same scenario. Unfortunately, by giving the user the ability to move the objects using a transform ability through the display pane, why would you not allow them to type in the world coordinates. It seems silly honestly, that you would not allow someone to align brushes in world space in exact measurements, and force them to visually attempt to align objects. For example, I have a box, and create a subtractive box just a bit smaller in the x and y scale. When I want to hollow out the box, I have to MANUALLY move the object in world space in hopes of exactly placing the box centered in the other box. I can not align them through ANY function within the interface. It seems as though the thought process of this feature is not totally thought out.

If we are given the ability to place the object using widgets, why could we not also specify the location using exact measurements? Please give us the transform window so that we may align/place brushes in their needed location.

Just adding a point here…
If an object has a tranform, rotation, or scale widget, then the should have a transform, rotation or scale section in the details.

The lack of an ability to scale geometry as pretty much just screwed me over. I’ve made a map for UT4 and the scale is slightly off. ALL I WANT TO DO is change the scale up by 25% (1.25x it’s original value) on the x and y axis but this is impossible due to the missing transform window in the details panel. The only thing I can use is the scale widget which is hardly accurate at all.

If anyone has a solution could they please pm me, i’m kinda desperate and really don’t want to have to completely redo the entire map :frowning:

This behavior is kind of ankward and undesirable. Imagine modelling anything in 3ds max when vertices transform are not exposed. At this stage, aligning anything it hell. One needs to visually connect everything which makes the whole brush system imprecise. I understand that you can’t actually parent them to anything but that still makes no sense why not to expose XYZ values.

:mad:

:frowning:

I’m going through the “starter” tutorials right now. This is one of the first things I came across in the tutorial. It says to adjust the transform of the box to be a certain size and scale, but there is NO transform window to do this in. But the tutorial shows that there is lol.

Sigh…I’m off to a bad start even on the beginner tutorials. Ugh. How can I flatten my rudimentary box geometry now like the tutorial?

Could you post a link to the tutorial so that I can see which exactly you mean? :slight_smile:
You can change the shape of the brush in the geometry edit mode. Just click on it - select your brush - now you can modify it like in a 3d program

24062028fc46257cfb29b70a9cf8e09f119ac605.jpeg

I have the same problem…

Blueprints → Tutorial working with components on Actors Part 1.

15c38d87bdd26d49c87e28c2bf0fee026a89a594.jpeg

Ohohoh, the reason was because something was written on the search bar…

On the “4 - Placing Actors in the Level”, I have encountered the same problem. I cannot seem to understand what the basic tutorial is trying to ask me to do. I am new to the software and I am unsure if it is a fault with the guide or a fault with myself, but I have done everything asked but the transform window never s

dfc677be04bfd5c4ab0a88f8a374916d78c6bd1d.jpeg

Has anyone figured this out? I’m struggling with the same issue as Drackn trying to do step 4 of the tutorial on page https://docs.unrealengine.com/latest/INT/Engine/QuickStart/4/index.html

But no hope of finding the transformation options

Thanks

Yup Me too.
Trying to learn from https://docs.unrealengine.com/latest/INT/Videos/PLZlv_N0_O1gak1_FoAJVrEGiLIploeF3F/57MxoF4sy84/index.html
The section, previous to this where the guy talks about hiding the character geometry… There is no mesh1P but there is a mesh2P and it has 2 guns. I think I was able to work around that though.
I’m going to keep on plugging and guess at the items that are misguided in tutorial.
Thank You though for having such an awesome suite!

I think I figured this out.

The problem lies in the fact that we initially selected a cube and not a box brush. In the newest release 4.15.1, the nomenclature has changed in the Modes Panel. The BSP entry, shown in the tutorial is now named Geometry. If you click this entry, you will see Box, Cone, Cylinder etc etc… Choose the Box and go from there.
HTH
Andy