No sound in UE 4.9.2


I don’t have any sounds in Unreal Engine, even though I tried everything I knew of.
In my settings, real time audio is at maximum, in the Editor preferences (Level Editor), I do have the Enable Editor Sounds checked.

I tried to uninstall and reinstall my audio drivers (Realtek High Definition Audio) without any success.
I know that I should have sound effects because I added something in my game (a destructible mesh) which produces sounds on destruction, which I couldn’t hear after doing it, but when my colleagues got it, they had the sound effects.

I also tried to hear a preview of an audio cue available in the starter content, and I just can’t hear anything.

I don’t usually have any problems with sound on games or softwares, but I had a few corrupted dll when I first started with UE (I reinstalled direct X).

Thanks in advance for any advices you may give me.

Hello ,

Just to cover all of our bases, can you ensure that your speakers/headphones are plugged in and that the sound is not muted by listening to sounds in another program? If you’re receiving sound outside of the editor, and are using windows, also try checking the system tray for a speaker icon. Left-click that and press the “Mixer” button. This will show different audio levels for all of the currently running applications that are capable of producing sound. Please ensure that Unreal Engine is not muted and that it is listed in that list.

If Unreal isn’t being displayed in the Volume Mixer, that would mean that windows isn’t recognizing that it is playing sound. Please try the various methods listed here to see if it’ll fix your problem. Redirecting

I don’t have any other sound in background, my headphones are correctly plugged, and only the unreal engine editor is open.

Unreal Engine is not in the list when I press “Mixer”.
I tried to check every options possible in the Volume Control Options, but unreal engine is still not displayed.

I tried the methods proposed and nothing worked.

However, something is puzzling me, when I click on “Play Cue” on one of the starter audio content, there is no “orange” on the link.

Is it a consequence or is it related to the problem itself ?

That would mean that it isn’t playing. Can you test Starter_Music_Cue and Fire01_Cue? I did notice that it seems like Collapse isn’t working correctly, among a few others

I tried those and all the others of the Starter Content with the mixer open at the same time to see if UE would appear muted as they say it should on the microsoft forum, but nothing happened

Can you check your playback devices (You can right-click the speaker icon in the system tray to see this) and ensure that your preferred audio device is being used? If it is, please try ensuring that your volume mixer is pointing to the correct audio device. You can see that through this option:


This menu is not available (I have the volume mixer but nothing happen when I right click on the Speakers, but as I already said, I do have sounds on everything else on the correct audio device).
I am on Windows 7.

I have a few things for you to try. First, open up your Playback Devices menu and ensure that your preferred method of output is set as the Default Playback Device (It should show a green check beside the icon). After that, try opening the editor and then checking the logs in your project’s folder under the Saved directory for any of the following lines:

“Failed to load XAudio2 dll”
“Failed to create XAudio2 interface”
“No audio devices found!”
“Failed to get DeviceDetails for XAudio2”
“Unsupported speaker configuration for this number of channels”
“Failed to create the mastering voice for XAudio2”

If you don’t see any of those, make a (or use an existing) code project and navigate to the XAudio2Device.cpp file in the Visual Studio project and set a breakpoint on the line that says:

bool FXAudio2Device::InitializeHardware()

If you’re not familiar with Visual Studio, you can set a breakpoint by left-clicking to the left of the line of code. A stop sign will appear. After that, right-click your project’s name in the Solution Explorer and select Debug → Start New Instance. If prompted to rebuild, press Yes. After that, the editor should launch. If Visual Studio doesn’t assert itself and show you that breakpoint, then that function isn’t being called and that’s the problem.

I was not able to do the debug (even though I found the line to put the breakpoint) because it is not compiling.

This version of XAudio2 is available only in Windows 8 or later. Use the XAudio2 headers and libraries from the DirectX SDK with applications that target Windows 7 and earlier versions.

I fixed that by adding in my build.cs :

But then after fixing it, I still have an other problem that I don’t know how to deal with : ‘Intellisense : identifier “UNiagaraScript” is undefined’ on the line UNiagaraScript* FunctionScript;

That last part seems like a warning from Intellisense rather than an error. Is it preventing you from compiling? I’ll look into why this would be causing problems.

In fact it is compiling, I was just not patient enough (it took a really long time for it to compile).
Here is the screenshot :

But even so, I still don’t have any sound.

Hey man, sorry you’re have so much trouble.

First, if you could post us your log files when you run UE4 from the EpicGamesLauncher when you experience the no-audio issue.

What is your system setup – what audio devices do you have? What version of windows? If you run a dxdiag on your system, it could help us identify any hard-ware things you’re experiencing:

The dxdiag has a bunch of stuff to analyze connected audio devices.

Also – just to be clear how UE4 audio works in windows. It essentially will always pick the “default” audio device of windows. We don’t currently support users selecting which audio device they want to use. (it’s on my list of backlog features to add). You set the default audio device by opening up the sound control panel and clicking “Set Default” on the audio device you want to use. Make sure the audio device works by right-clicking on the device and specifying “Test”.

As for getting that error about XAudio2 version, that indicates to me that something is wrong with your setup and compiling UE4. Microsoft decided to move Xaudio2 around for Windows 8+. Good news is you shouldn’t have to worry about it with UE4 since we distribute everything you need ourselves. You definitely don’t need to modify any Build.cs files to build anything. The fact that you’re also seeing other linking issues implies something more fundamental is going on.

If you want to compile UE4, lets backup to the beginning.

I apologize if you’ve done all this before, but just in case you’re not building correctly. Make sure you follow these instructions (including the part about downloading the source):

Now, assuming you can compile after following the above help, if you’re still having audio issues with your device, make sure you look at the log output of UE4 for any of the log errors/warnings mentioned above.

If you’re comfortable with getting a bit dirty and learning some new tricks (if you’re not a programmer), find this file:


In that file, check out this function:

bool FXAudio2Device::InitializeHardware()

Add a “breakpoint” (select a line of code, and push F9 to toggle a breakpoint, this will cause everything to stop at that line when the editor is running).

Then, make sure you’re compiling the Debug Editor (not Development Editor) configuration in UE4.

Then, when you build/run the UE4 Editor from Visual Studio (the green button), you should “hit” that breakpoint during launch of UE4.

Then, all you gotta do is push F10 to step through the function. See if anything triggers any errors or warnings or anything else.

Hello ,

We haven’t heard from you in a while. Are you still experiencing this problem? If so, can you try the methods that Aaron suggested and let us know the results? In the meantime, I’ll be marking this issue as resolved for tracking purposes.