Download

No Smoothing Groups found... ugg...

okay… so the error:

“warning no smoothing group information was found in this fbx scene”

exported a mesh using fbx 2012 export, didn’t work, 2013 export, didn’t work, 2014 export didn’t work.

exported a mesh to obj, converted it with autodesks model to fbx - didn’t work.

exported from max, didn’t work.

exported from blender, didn’t work.

so… I was getting frustrated, and just to see if Maybe just maybe it wasn’t me…

Exported a mesh from Unreal 4.9.1 sample scenes, Imported them into Ark, hey guess what? The same damned message.

No matter how the mesh is exported I’m getting “No Smoothing Groups found”.

This wouldn’t be a problem but, when you get up close to the meshes in first person (being they are organic) They look like total ****.

Now I’ve looked this error up all over the Unreal forums, all over the web and in every case, the one result that I seem to be finding is Unreal blaming everyone elses application exporters for the error popping up.

However if the Error is happening with Importing meshes that were exported from the Unreal 4 engine (4.9.1) as well, It looks more like its a isssue with the importer for Unreal 4 Engine rather then everyone else. To top it off, Exporting a mesh to FBX and importing it into 3d studio max, blender, Cinema4d, guess what? all the smoothing groups load in :open_mouth: amazing!

To top it off if your looking at the model within the Model Viewer in Unreal 4 Engine, it actually has smoothing applied, but when putting it into the game, hrm… guess what? it seems to of tossed that smoothing out the window (even if you save the file).

So What gives? Whats the trick? I’ve tried every solution that I could find on the net to get this working. Setting pong shading to not to break on edges, making sure the ‘export with smoothing’ is checked, adding a skeleton, forcing explict normals, and nothing is working. So what the trick to getting these damned Fbx files importing into unreal properly? I’ve gotten tired of fighting with this all day, and would actually like to get the model in to the game so that I can continue onward and get the other stuff done…

You don’t actually need smoothing groups. I found it imports them just fine.

Make a organic Mesh, then get up close to the model and look at it before you apply a texture - notice you can see EVERY poly do to no smoothing getting imported. It looks nasty as hell, doesn’t look fine to me at all.

Are you sure you checked the ‘Smoothing Groups’ option on the FBX export of max?
And are you sure your mesh has Smoothing Groups?

Worst case scenario - it could be either the XForms of the mesh, or the normals. You could try add an Edit Normals modifier, select faces, ctrl+A to select all - and hit reset.
Make sure all your verts are welded too -

These are all just ideas off the top of my head.

If you want, PM me with a dropbox link to the mesh and I can take a look for you :slight_smile:

yes, and like i said… if you export a asset from one of the “sample” scenes from the Unreal Engine 4.9.1 that has smoothing then import it into Ark you get the same message. No Smoothing Groups Found.

Its not just a issue with just a specific Modeling application.

I am getting the same exact message if i export a fbx from cinema4d and import it directly in ue/adk.
This is because cinema4d has something call phong tag instead of smoothing groups.
A easy fix for this is to get example maya 2015 import the fbx, export it with the 2014 exporter. and set smoothing groups checked.

As of the white edges on your edges i can think of two things that causing it. texture bleeding. make a uv map that has a bigger padding between the uv’s
second thing is that your normal map is missing or its to weak, might even got a wrong tangent direction.

the edges your seeing is a result of no smoothing. If the smoothing would import into Ark then you wouldn’t see that issue happening.

i dont get that error but i had also turned smoothing group on when i do export from maya