Download

No shadows on 3rd person character

Hi,

As title says I can’t get shadows to appear on default character that comes with engine ( blue robotic char.), and Ive checked everthing, but all seems fine, anyone know what might cause this ?

Thx
nl

Go into your character blueprint - click on the character mesh in the component tab - search for shadow and check if cast shadow and cast dynamic shadow is activated :slight_smile:

Are you using Preview 6 of 4.7? I’m having a similar issue and I think it was talked about in the 4.7 thread.

@KitatusStudios: That issue with stationary lights only. We didn’t notice anything wrong with dynamic lighting that I’m aware. I know that issue is fixed in our internal build and will be fixed with 4.7 p7.

@neighborlee: Are you still on 4.4.3 or are you using a later build now? Also, check that your lighting is not only static. If it’s only static this would make sense since it cannot cast any dynamic shadows to work with your character.

Oh shoot. Shall I try and replicate and submit as a bug then if I can replicate? :confused:

Definitely let us know! :slight_smile:

Im still on 4.4.3, only because I’m heard too many issues with 4.6/7 , plus I really didn’t see any new features that I felt could help with my current WIP, maybe I’m wrong about that . Mainly it waS me being a bit worried about stability since I"ve already had terrain issues that were only resolved by fiddling with settings . Smooth detail checkbox was on and seemed to be causing this issues, but lately I thought what if I flatten the an area that I could not sculpt or smooth over ( brush could not enter the area at all as if invisible barrier was there ), and while it was very stubborn in fixing, I now don’t get spikes nor atm anyway or there any areas I can’t sculpt or smooth.

I have no idea what it might have been, short of I imported a terrain exported from unity, but given there is a import raw function which this was, I really have no idea how I could even file a bug report , not ever getting any error messages during import of that raw terrain file, or during editing of said terrain. Anyway I will check for the issues fighter mentioned and edit this post >

EDIT : all lights are dynamic, and all have cast shadow checked, still no character shadows. I can’t get them to work in any of my levels, very confusing. Also worth noting, I did verify that in component area of mesh, cast shadows is checked as well as dynamic shadows.

Given we are so close to 4.7 rel it would seem prudent to wait a bit longer I guess ?

Ty so much for your continued support Tim.

Cheers
nl

There is no problem that I see with sticking with a build you have until you absolutely need the new features provided by a new release. This is how successful game development happens. It has always been recommended to stay on a build until you need to upgrade, so I fully support that choice! :slight_smile:

With 4.7 there are a lot of improvements that have been made since the release of 4.4.3 with foliage and landscapes. Large world support has been a continued request from the community for a long time and things are moving in that direction to better support these types of things. There are some cools features that have been talked about on the Twitch streams coming down the line for the next few releases. My recommendation would be that once 4.7 releases and the notes are available, take a look and see if there is anything you can’t live without or even would like to just test in the new build to see if it fits your development needs. It may or may not depending on the point you are in your project.

I don’t know if anyone saw my EDIT, but I still have no shadows on my character , even though cast shadows is set on all Scene lights, plus under components in character blueprint, I also have cast shadows on static and dynamic, so any idea what else it could be ?

thx
nl

I ma the same way but i think my version is abit older. I am also running this on an old laptop with 512 mb or video ram.

Some other suggestions to check:

  • Is this only happening with this project or if you create a new project do you see shadows on your character?
  • Can you check the Engine Scalability settings and put them on Epic if it is not set there already?
  • Is your character the only mesh that not getting any shadowing?

Ok yes turning on EPic is bringing shadows back, but I think its certainly messing with my framerates :wink:

I can’t get shadows to look even close to good, unless I use epic setting on shadow under editor quick setting, is this just due to the first ‘quest’ mesh having no current uvmap for lighting, causing this ?

cheers
nl

If you’re getting low FPS this is why the engine scalability is kicking in and lowering the setting to get better performance.

As for the UV, if you’re not using any static lighting then a lightmap is not necessary.

Some things that may help performance wise would be to use static lighting with properly setup lightmap channels for your meshes and build lighting so that you have baked shadows or in the viewport turn off real time unless you need it on during specific instances. This can make it easier if your FPS keeps dropping like that on the EPIC settings.

The terrain is very large as is the mesh sitting on top so I can’t be horribly surprised that I get 30 fps or so,plus I have a Athlon X3 3.2ghz, 8 gig of ram and the weakest link is my HD 7750 2gb GPU. Using the UE4 editor takes a beefy ISh rig, so I know someday I really need a upgrade ;)) When I start adding objects and textures and other features, Im sure it will go from nuisance to necessity .

Feeling good about scene , have a good day TIm :wink:

Cheers
nl

Hi Tim.
I have a feeling this issue might be back in 4.16.2.
I just upgraded from 4.16.1 and suddenly I am having shadow issues on dynamic objects like destructibles and character when my
indirect light and directional light sources are set to “stationary”.
(This was working fine in 4.16.1 and I didn’t change anything)
If I set them to fully dynamic then the issue goes away but the shadow quality doesn’t look very good.
If you don’t mind taking a quick look at my thread here:
https://forums.unrealengine.com/showthread.php?149015-With-upgrade-to-4-16-2-(from-4-16-1)-suddenly-my-dynamic-onjects-weird-shadowa-issue

Thank you!!!

Hi Tim.

This issue popped up again in 4.24.
I am using the SunSky BP without the standard sky BP.
I have a spot light over my scene facing straight down.
If I make it a dynamic light then meshes between light and 3rd person character cast nice shadows on character no worries.
However the scene looks weird.
Seems to be issues with interaction between new SunSky BP and standard lights.
If I make it a stationary light the lighting looks best but no shadows of meshes in between light and character is casted over the character.
I tried doubling the meshes up, make material double sided, added blocking volume and set it to cast a shadow but nothing works.
If I set the spot light to static it looks terrible.
I have a workaround I will simply remove spot light because its just a working light anyways (scene is dark with sunset sky).
I will add smaller lights and avoid having anything between lights and character.
But just to let you know :slight_smile:
I have lightmass importance volume.
I have post process volume and auto exposure is disabled I set min and max exposure.

CORRECTION : As movable light everything looks fine I just have shadow resolution issues with character on the floor but that is probably something else.
So as movable light everything is fine, as stationary light no shadows on 3rd person character.

I still have no shadows, cast shadows is indeed set on directional light, 4.24.3, very odd. I’m not using Sun & Sky though I was, but was having terrible time getting decent visuals.
Any idea why I’d have no shadows ? In the meantime I guess I’ll go back to Sun & Sky see if that does anything.

Any chance edit settings is off somewhere, checked but under shadows I see nothing wrong.

I hear 4.25 will fix lighting, I wonder if this no shadow on terrain OR 3rd person character is a result of this …

Very odd, no shadow on stock 3rd person,and I know cast shadows is set there too.

Dain odd, ok switching back to Sun & Sky brings shadows back, sure be nice to know why they weren’t there in non Sun & Sky,lighting is such a pain in my side , maybe hope for ray tracing when I get a slightly beefier system/RTX 2060 , am4 etc.

Its just something I am sure they will fix at some point.
Its most likely a performance issue.