Download

No Quixel Bridge for 4.27 .. yet ?!

It looks like there is no plugin available for UE 4.27. Is it coming any time soon ?

Plugins always lag behind releases. 4.27 support should be coming in the near future. Thanks for your patience!

J. Holmes
Quixel Community Support Lead

3 Likes

4.27 support is out now!

https://help.quixel.com/hc/en-us/community/posts/4406167791505-Megascans-Plugin-for-Unreal-Engine-v7-3-What-s-new

J. Holmes
Quixel Community Support Lead

3 Likes

awesome! thanks