Download

No Quality Assurance With Asset-Engine Compatibility From the Unreal 4 Marketplace

For nearly two years I’ve bought a handful of assets from the marketplace that are not compatible as advertised. It has happened at least three times from new and old asset releases and between music, particle effects, blueprint and model assets. I’ve tried restarting my computer, clearing caches, deleting local content, installing different engine versions, restarting the epic launcher but nothing has worked.

In recent memory it has happened to me with

Mothership Scifi Assets (materials/textures not compatible on 4.8 last time I checked a few months ago),

Tower Defense Kit (not compatible on 4.8 last time I checked a few months ago),

Cinematic Music Pack (Used to be compatible but the author says he is waiting for Epic to implement updates)

There have been other assets I’ve purchased and given up on that were falsely advertised as compatible with versions under 4.9/.10 but did not work. Right now I am struggling to find a receipt for the Cinematic Music Pack 1 that I bought a year ago because it won’t unpack for me under 4.7-4.10.1 while going through the tedious process of validating my purchase to the creator and waiting to see if the credentials I give is enough to use content I paid for.

I love Unreal 4 but the marketplace has been one of my biggest frustrations throughout my experience. I’ve tried to e-mail creators to check if their projects really work on the older engine version that is advertised before spending money, but most don’t honestly test it or expect me to buy and try it myself.

This problem has been persistent and extremely aggravating and I hope if any content creators read this to please just check if your assets still work on the Unreal Engine versions that are advertised.

A problem with the marketplace is that they are marking the assets’ compatibility incorrectly. Take for example the following:

A blueprint asset releases on UE4.9 and the launcher is marked as compatible with 4.9. Fast forward a few weeks and the creator correctly updates their submission to 4.10 as EPIC instructs us, but has to update some depreciated nodes from 4.9>4.10. Epic then marks the launcher compatible 4.9-4.10.

Problem is if someone is running engine 4.9, sees compatibility and purchases the content. Auto crashed their engine on startup. A bad review comes in. They email the support email. They are told what the problem is as described above. Suggests them to update engine version or ask for a refund. They can’t move to new engine version for whatever reason. Refund is issued. Customer has a bad experience, seller has a bad experience, and we get threads like this. What EPIC needs to do is take whatever version of your engine is currently selected and download that previous version of the asset. My guess is that EPIC does not keep these old versions and throws them out to replace with the latest update.

Thanks for the insight Osok, I was afraid something like that was happening because some creators were confused about the trouble I was having with the backwards compatibility for their assets when right clicking projects and switching Unreal versions wasn’t working.

We’ve had to do a few overhauls on our project to catch up with engine versions but having a music pack unable to be added from the marketplace brought this situation to a point where I have to bring it up.

Thankfully I got in touch with the asset creator for the music pack and have the content in order, but I’ve also had to deal with buying expensive packs and waiting days to see if the creator would send a working download link, miss the e-mail for a few hours, link is disabled, re-sending another e-mail to reactivate the link and hoping they’re still at a place that they can help me with my problem.

Just wanted to see if the Mothership Service Rooms asset pack was still incompatible with 4.8.3 (even though it says it should work)

6Ewdph8.png

To my surprise it does not add its files to my project, and then I read the comments section,

iVXbkM9.png

Sadly this is not the only asset I’ve bought that included this problem and the whole situation is maddening.

Epic should stop marking compatibility with old versions at all and instead place disclaimers everywhere that users need to make updating to a new engine version a priority with every engine release.

The low quality assets ported over from other engines are a much bigger problem to me.

I appreciate that Epic tries to let people work at their own pace since their engine updates come at lightspeed and in some cases updating a project to a newer version means more work than using the right-click function.

Just had to check again if a blank 4.10.1 project would receive the Cinematic Music Pack 1 successfully, but it does not, and this was not the case during 4.7 and 4.8.

Is this a typo, or are you having an issue with backwards compatibility? Forward compatibility is all that is mandated for the marketplace, nothing prior to the base version that is submitted has to be compatible.

Most projects come to a point where updating the engine version isn’t optimal at all and can cause more work than it’s worth.

I’m only looking for the compatibility that’s advertised on the asset from the marketplace, I would not expect an asset in 2016 to be able to work in Unreal 4.4 for example, sorry for that confusion.

The FPS Tower Defense Toolkit is the product you’re referring to in the main post? If so the base version is 4.9, not 4.8. The issue with the Mothership Service set seems to have been an error on the marketplace staff’s part according to the author. The Cinematic Music Pack is showing compatibility for 4.6-4.10. You mentioned it doesn’t work in a blank 4.10 project, but I’m assuming it does for previous versions? 4.6-4.9? I’m not sure why that would be labeled 4.10 compatible if the creator said he’s still waiting for them to implement the update.

With the case of the FPS Tower Defense Toolkit, there used to be a 4.8 base version but the updates were only continued using 4.9, I brought this up in a ticket with Epic in October and they may have corrected it since then and they offered me the refund.

The Mothership Service set should work in 4.8 as advertised since I’m only expecting 3d models, textures and materials. The meshes get added with no problem but the materials/textures do not. I haven’t gotten around to asking for a refund on this asset because I’m pretty sure it would be too late.

I’ve tried to get the CMP working on 4.7, 4.8, and 4.10.1 with no luck, I don’t know any more details about the update or problem with that.

That explains it for the toolkit then. If the base version has changed, then it is unlikely that it will go back to 4.8. It may have been a similar mistake such as what happened with the Mothership Service. While yes it is advertised as 4.8, this wasn’t at the request of the author according to the comment on his product page. He should have contacted Epic about this upon being notified of the error. The comment referencing this was all the way back in November, so either he/she didn’t or it got lost in the ticket queue. Submit an email to marketplace-support@unrealengine.com informing them of the issue and they should be able to fix it. I’m not sure how long you will have to wait though, as they are apparently on vacation until the new year. I’m sorry to see you’ve had these issues for so long. Hopefully the staff can get it sorted for you very soon.

Also, I’m curious what sort of errors are you getting when you try to add these packs? Does it simply not add them? Or does it say “incompatible with engine version” or something to that effect?

If this were the case, then I can see it being the cause of the problem. There are some things present in newer versions of the engine that aren’t in prior. It isn’t false advertisement. The base version on a product in the marketplace marks the version it was submitted under. However I always thought that they created separate projects for each version, which are then selected from the dropdown for download to your specific version. This has always had me curious as to how they could sustain the content sizes a year or two out from now with multiple subsequent engine releases. We probably won’t solve this question until one of the staff members drops in and clarifies. But if your suspicion is correct, it would explain why some of these projects are having issues like this.

Referring to what I see when I add the content,

It adds them but they don’t show up in the Unreal 4 editor, only through Windows Explorer and packaging leads to the ‘incompatible engine version’ you mentioned.

When it comes to asset compatibility, it should only take a few seconds to check which versions work before Epic hosts the asset on their marketplace, even if it means less marketplace assets for older versions to play with, I wouldn’t have to deal with the refund/e-mailing creators process.

Anyways thanks for your help Jon, hope it gets changed, not expecting anything else.

I feel pretty certain about this. Like you said, the amount of space wasted on old versions from like 4.4 etc would generally be not worthwhile. I have personally been affected by this recently due to the depreciated nodes in my blueprints. The releases come so fast I am thinking EPIC needs to host at least the current and previous versions of the asset.

Thanks for the information. I definitely agree with you on that and understand your frustration. Please keep us up to date on this, and let us know if the marketplace staff is able to resolve this for you. =)

If that’s the case I’m not sure what the point is in having previous versions marked for compatibility. The whole point is to have the project that is compatible with and works flawlessly in x version, whatever it may be.

I think Osok is right here.
Whatever engine version a pack is first submitted for, it should remain compatible with that and all later versions for as long as it’s on the marketplace. It’s completely unreasonable to expect buyers to just update their engine version.

So, there’s really no other way than Epic keeping hold of a pack for each engine version, and making them all available for download. Sometimes it just won’t be possible to update a pack to a new version without breaking it for previous versions.

I don’t think sellers can be expected to support and provide fixes for older versions, but they need to be kept available at the least.

Is it expectable from sellers to down grade their assets?
I mean from 4.7 to 4.10. That can be impossible for some bp projects.

No one’s suggesting that they should. This is just about cases where an asset was originally released on an older version of the engine and then the mandatory upgrade to the newest engine version ends up breaking the compatibility with the version the asset had originally been released for. So a version of the asset which is compatible with this older engine version exists but Epic is simply not letting users download it anymore.

We might want to get a moderator to move this thread to the feedback section and give it the [Marketplace] tag so that the staff can see this. I don’t think they look to this forum for feedback anymore.

I recently got contacted by someone who purchased my cave package around 4.6.
He now runs his project at 4.9, saw an update available for my cave package (4.10 update).
So he updated it, not knowing it would result in breaking his project.

I did forward the email conversation to Stephanie.
I always thought that previous versions where being kept by epic…
Heck, I don’t even have the 4.4 - 4.9 versions of my cave pack anymore as they where bug-free.

I really think that Epic Games need too revise their strategy here.
They need to ensure that any package would keep working regardless of the Unreal Engine version being used. And that no plugin/package would break any project like that.
Unreal Engine 4.x is a very good product but it seems that Epic Games is quickly losing control of their own creation with so many updates and a lack of compatibility layers to ensure that customers don’t lose their precious work and money. And the API documents are far from good with most of the C++ code undocumented and so completely unknown to anyone other that the Epic Games programmers themselves.
I am going to start my first game project soon and I am quite worried of having to deal with compatibility issues whenever I would need bug fixes and new features in a new UE4 release but upgrading would then cause some serious troubles with the project at a later stage.

Apple with iOS more than OSX changes a lot of APIs code and adds many new APIs but their online documents are almost always up to date and a developer can quickly browse and find how things work.
I understand that Epic Games is not as big as Apple but it is not a small software house either. If they need to hire more employees to ensure UE4 quality then what are they waiting for? Things are only going to get worse if no one can keep up with all the new UE4 versions.

Epic must keep available depricated blueprint nodes for ~1 year.
They can’t simply remove a depricated node next time engine is updated, that is plain silly thing to do.