No Option to Set Collision Complexity?

You can use the search bar at the top, using “collision” to help narrow down where it might be.

However, I’m pretty sure you have to set this in the static mesh asset editor (not in level)

I’m doing the tutorial for blueprinting. In the tutorial I’m supposed to select my static mesh and select “use complex collision as simple” from the Collision Complexity drop down menu. Unfortunately that does not exist in my editor and I’m not sure why.

As ConradG says, that option is in the mesh editor: