No obb found or store key to try download

I know that there is a lot of topics with the same question but no one of the solution didn’t help me.
When i try to open my game on Android device always the same fault: “No obb found or store key to try download…”
But at the same time Tappy Chicken work perfectly, i tried to copy all settings, but it didn’t help.

Qwentum,

The verify disable doesn’t disable making sure the OBB is present, it just makes sure it doesn’t try to validate it. If you package with an OBB it must be present; you cannot run without any data. The batch file you ran doesn’t copy the OBB to the device.

Please explain exactly how you’re pushing the batch file to your device.

Thanks!

I personally connect my device to the computer, accept the ‘fingerprint’ on the device and doubleclick the .bat file. It launches its own command prompt and installs the project onto the device. You must wait for it to completely finish. Sometimes when a project is large, it looks like it has failed or isn’t working and then you open the project too soon and this error pops up.

If you’d like me to test your project out here, please provide me the whole packaged project folder in a private message on the forums.

Thanks!

Dear Samantha!
I will be very grateful, if you’re test my project. How do I write to you in private messages? I can not find this feature. Once again, thank you very much. Best Regards, Qwentum.

You should be able to find a link to send me a private message by viewing my profile.

Thanks!

Dear Samantha! I’m sorry, I’m wasting your time on such silly questions. I found only under “add to friends” and has sent you a request. And once again I’m sorry to take away your time!

I dont know why but its writte: Qwentum, you do not have permission to access this page. This could be due to one of several reasons:

Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else’s post, access administrative features or some other privileged system?
If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.

Add Samantha Sutton to the following ‘To’ section in the forums if it’s not already auto-populated.

Thanks!

Once again, sorry, it’s just very important to me. There is no other way to send you to the project? Mail / Skype or something - anything? Once again many thanks for your help. Best Regards, Qwentum.

Many thanks for your help! You’re a very good man. Here is a link to the project: https://yadi.sk/d/S42C6foBy47c6
Once again many thanks for your help. Best Regards, Qwentum.

So I packaged your project for Android ETC2 and installed it on a Galaxy S6. I did not run into any trouble with the OBB file. I did not change any of the settings in your project. Are you sure you’re waiting long enough for it to install?

Your Google Play app isn’t available for my country. Could you make it available for the United States? Could you show me a screenshot of what you actually uploaded to Google Play?

Please follow the directions in this documentation: Firma tu app  |  Desarrolladores de Android  |  Android Developers

You need to make sure that your key store is properly updated for distribution to the Google Play store.

If you’re still running into the OBB file issue after you’ve updated your key store, let me know.

Thanks!

Dear Samantha! I made my key with Android Studio, but unfortunatly it didnt help. I uploaded one more app for test in Play Market with new key store, but error still the same:(

Dear Samantha! So i tryed to find some solution, and you wrote that you packed my game and launch it successfully. Can you packaged it again and send me? I think maybe it could be problem with my computer or something. With great respect, Qwentum. https://yadi.sk/d/4eOaghqoyhdoX

Qwentum,

Since you’re having trouble when uploading to the app store, please go into the advanced mode and upload as an expansion.

Thanks!

I am not able to package the project and send it back to you. Do you have another computer you’re able to test on? Make sure you follow the steps in the Forum Post.

Thanks!

So, i solved my problem. These some important things that may help someone who will have the save error:

  1. Set “Shipping mod” , full rebuild, for destribution , unclude prerequisites.
  2. After, make your keystore Signing Projects for Release | Unreal Engine Documentation
    ( i tried to make key with android studio, but it did not work ).
  3. After make sure that you add expansion file ( your obb file ) in advanced mode.
  4. Dont forget to check that you install all CodeWorks that you had to.

So these links were helpfull for me:

https://docs.unrealengine.com/latest/INT/Platforms/Android/GettingStarted/1/index.html

Hi there! I am having the same problem. Made everything but, could you please let me know what you mean for “make sure that you add your obb file in advanced mode”? Can’t figure out where to set that

I had the same obb problem when I was manually installing the apk in Android Device.
I installed it through “Install_AppName-Android-Shipping-armv7.bat” file and now it works on mobile perfectly. No need to set up keystore if you are not publishing yet to Google Play Store.