'no media player plug-ins are installed and enabled in this project'

I do not usually turn for help with issues that I am enduring as I can usually resolve the issue or find an answer for myself, however it seems that nobody else is experiencing the issue that I am currently having and searching for it leads to a dead end on Google.

When trying to package my project I get this error:

‘LogMediaUtils: Error: Cannot play file://C:/Users/cplna/Documents/Unreal Projects/Project/Content/Movies/video.wmv: no media player plug-ins are installed and enabled in this project’

However to my confusion media plug-ins are enabled in the project. From the thread that I found it was suggested to try a different format and frame-rate for the source video.


I have tried the suggested WMV at 24fps to no luck, my thought was that the engine could not find a valid media player for this specific format automatically.

So I have tried setting it manually, this gives me a different error:

‘UATHelper: Packaging (Windows (64-bit)): LogMediaUtils: Error: Could not find desired player WmfMedia for file://C:/Users/cplna/Documents/Unreal Projects/Project/Content/Movies/video.wmv
PackagingResults: Error: Could not find desired player WmfMedia for file://C:/Users/cplna/Documents/Unreal Projects/Project/Content/Movies/video.wmv’

The source video plays perfectly fine in the editor, only when it comes to packaging does this happen.

My thought is that when set to automatic it cant find a valid player, maybe that is because the video format does not fit the criteria for any of the media players? or maybe its because the media players are not being properly loaded?

I suspect that it is the latter because when I try to manually assign them it gives me the error that it could not be found. I am really not sure why this is the case and it seems far beyond my scope, perhaps this is a bug with the engine?

It should also be noted that I built from source on what I think was a ‘promoted’ branch, apparently this is version ‘4.22’. I might try to go to the latest stable release to see if that helps.

Anyway I really hope that this longer post helps resolve this issue and doesn’t turn people away. I am truly stuck at a roadblock and hope that I can be helped, thanks for reading!

I have tried installing the latest 4.20 build of the engine, including WmfMedia & Media in the .build.cs file. Not sure if its something I am simply missing because it only fails to package.

Have you found a solution for that issue?
From my experience unreal just wont accept the fact I enabled the media plugins and wont add it to the list of activated plugins :frowning:

Nope, never found a solution ended up just putting it on hold for now.

I think it’s best to post on the forums if you want an actual reply to issues.

Ran into this issue and finally solved it by moving my MediaPlayer->OpenSource(FileMediaSource) method from the constructor to Tick, or anything in runtime. The media players must not be loaded on construction.

Hello , i had the same problem but now its solved , i think the problem was the Windows media player and the Media features pack was missing, i’ve added them and it worked like a charm.