No matter what I do the Character goes through Walls

Have you tried enabling CCD?

No, it’s in the character capsule component.

Even though i`ve set up the collisons my character keeps going through walls (If i try hard enough and and move around the camera near a wall) and sometimes even floors!
I am using brushes.

If I migrate my character into a FirstPerson Preset, the problem is still present.

I have tried the following:

• Decreasing Near Clip Plane

• Positioning the camera inside the Capsule

• Increasing the size of the Capsule

• Decreasing the size of the camera

• Adding a Collision Sphere

• Setting the Nav Agent Radius to 150

• Copying the pre-set of the FPS that comes with the Engine

Here are a bunch of screenshot of my Character Blueprint. Ask more if needed!

Thanks for answering. In Project Settings I can only find a “Disable CCD” property. This was disabled

Just tried, unfortunately it didnt change anything :confused:

Have you changed the collision settings on the sphere? In the details panel there’s a collision drop down menu, you’ll need to change that to block all.

Hey Wyldcard, there are so many options and moving parts I’m not sure you’ll get a solid answer here.

I think to find the solution, you will need to trim the possible problem space.

To debug this, I’d do the following:

  1. Create a new FPS shooter project from the UE template
  2. Migrate your pawn into that project.
  3. Experiment and compare your pawn to the template’s pawn.

if its just the camera doing this then based on what you have in your blueprint component section, my guess is your issue may be related to not having a spring arm. By having the camera locked in relation to your capsule component you can potentially move it passed walls and floors. The Spring arm acts like a variable distance arm that when it detects the camera attempting to clip, it will bring it forward. Heres the documentation page on it. Using Spring Arm Components | Unreal Engine Documentation

There are also a couple visualization modes you can try to narrow down your issue. You can go to show in the scene view and enable show>collision to visualize the collision geometry, you can also change the view mode from lit (the normal view) to player collision (hold ctrl+alt over the options to get more info) and it will show you the scene as it is via collide-able objects.

Did you try just changing the collision on the character capsule to ‘block all’?

I changed all the components + root to block all, the collision views shows the bsp to be dark purple. The character still goes through.
Honestly I didnt think Unreal Engine was like this, this feels like such a basic thing and it doesnt work. It`s not like the character “just goes through”, it bugs out and clips and then it goes throug

Yes I tried all sorts of settings with that Collision Preset, now they re all on Block All. It just doesnt work.

Nice! Thanks for following up and good luck with your project :slight_smile:

I Solved this by removing the Camera component and disabling the Use Controller Rotation Pitch from the Character Actor. The character was going through walls because it was leaning forward and backward.