No Info on Importing Groom Hair - a mystery!

When you try to import it gives you 2 options - OBJ, and FBX
Then if I drag the ABC’s folder into the content slot, it only lets me pick Geometry Cache
How do you import ABC as a groom, or assign it so it will be imported as a ‘Groom’.


No info? Did you even check the documentation? It has a step by step quick start guide:…art/index.html

Yeah, I don’t think so guys. It leaves out how to import specifically as a groom vs a different type of ABC.
I mean, what if I wanted to bring it in as a normal ABC and not a groom, right?..

When I click IMPORT and select the ABC, it only comes up with options “Alembic Cache Import options”
(1) Static Mesh
(2) Geometry Cache (experimental)
(3) Skeletal

It does not say “Groom Import Options”

Then, in the instructions, look what it says:

“2. In the Content Browser, click the Import button to import your Alembic file with your groom.”

But how does it even know to differentiate the ABC of a primitive cube, say vs a curves-hair. Something weird here not detailed well in the instructions!

Like, how is it supposed to know to set up the dialogue for "Groom Import Options"?


For a groom you’d import curves not geometry. If you do that, UE4 will automatically read it as a groom as opposed to a regular alembic.

I’m having the same problem here. I’ve just tried exporting my description from xGen in a million different ways but seems like the groom import plugin won’t work. It doesn’t recognize there’s only curves in my alembic file. If someone has encountered the same issue and knows a fix… please help!

For you guys have problems exporting XGen for Unreal, i coded a script because exporting was so tedious, i hope this helps you too:

Same issue here. I am using blender hair. No import options as a groom. Anyone solve it?

1 Like

I ran into the same problem. The solution is, in Blender:

  • particle properties → render → uncheck show emitter
  • export → uncheck renderable objects, check visible objects

The hair .abc file generated with this Blender setting will be recognized by UE as groom, and the groom import options dialog will be shown properly. :sunglasses:


1 Like

Thank you but I am not able to get this working between blender 3.1 and unreal engine 4.27. It still shows the regular alembic importer not the groom one.

Out of the blender reload the ABC file, delete anything other than the particle system in the outliner, and import it into the UE, it will be recognized as Groom.
In my case, a plane was inserted.

UPDATE: 10 months ago, I fixed my problem. I just needed to select the both mesh AND the skeleton, rather than only one thing or the other, when exporting from Blender.

thank you, visible objects check was the solution for me.

Can confirm, still works for Blender 3.6 and UE 5.1