No ground box collision in PhaT

I have been having an issue for a while where nothing collides with the ground box inside the Physics Asset Tool. It seems to be localised just to my current project but it affects all Physics Assets.

Any asset I import including migrating from starter projects and even the Physics Assets in the engine content have the same behaviour, however if I create a new project I have no issue and all Physics assets including custom imports of my own behave properly. This only happens in PhaT outside of that tool everything works as intended but it makes it hard to get the collision boxes right. If I am quick or I turn gravity off I am able to grab the object with Ctrl-RightMouse but it still does not interact with the ground box.

It seems likely that this is something that I have done accidently at some point but not sure how or when, I have looked through the Project Settings and everything in Collision and Physics seems to be set to default except for a few custom object channels that I have created none of which are applied.

If someone has encountered something similar or if I’m missing something obvious a point in the right direction would be greatly appreciated.

Fixed in 4.16

Hi, Bizmark

I came across the same issue as you. Just no ground box collision in PhaT and affects all projects created by this editor. I suspect maybe there is something wrong with the import settings or editor settings. Could you please tell me how did you fix this except updating the engine version or maybe more info about this issue?

Thank you very much.


I’m sorry the engine update was the only fix I had for it. I didn’t look into it after that, as my problem had been fixed. Hopefully you found a solution.