Download

No google playstore key, Obb not found

I have an Android project with UE 4.24. I’m able to run this project from the Editor on my device. However, when I try to package the game and when I deploy it on the Google Play Store, when I get it on my phone I have the message “No google playstore key, Obb not found” and I’m unable to start the app.

I don’t have the possibility to package the game data in the APK as the size of my game is almost 2GB. Is there any other workaround or solution to this issue?

You should always use expansion files (.obb) for your builds to GooglePlay.

I have an expansion file (an OBB) created. The OBB is then uploaded to the Google Play store and attached to its APK. Yet I have this message.
I have also noticed something: if I use the generated .bat file to manually upload the game on my device, it works fine. It’s only when I’m getting the project from the Google Play store that I have this error.

I’m still looking for the cause of this problem. I’m adding here new informations from investigation: when I upload the APK and the OBB manually using the .bat file, the OBB file is placed in /sdcard/Android/obb/my.package/
When I get the app from the Google Play Store, this directory is created, but remains empty (even though the download of the app was including the size of the OBB).

Also the behavior is different when it’s just after a restart of the phone or later.
After a fresh restart, the Google Play store will start the download of the APK (according to the downloaded size), then will get stuck for a moment, then it will download the OBB. After the completion of the download, it will say that the app failed to install (but it will still appear in the list of apps).
If I retry a new installation of the app just after, the download will start and run without any problem. But when it’s finished, the OBB is not installed and the app is not working.

I would suspect a problem with my phone, but actually I have a co-worker who is using another phone and who has the same problem with the app, so I’m starting to think that it may be a bug of UE4.

Are you getting the same issue as described in my post ?
https://forums.unrealengine.com/deve…-on-android-10

Which devices have you tested it?and which android version? i tried 4.23 and 4.24 binary, but no luck

In my case, sometime i get an error from googleplay when finished, but most times not. Also when i launch the app and it starts to download the obb again, after some seconds it will try to open it before it gets downloaded and will result in crash. BUT if i minimize it when it downloads, it will download the obb and once finished i can launch it. Tried on a mi5 Android 8 and on mi8 android 10, and i did not get those issues. only on mi9 with android 10 i got this, but am sure there will be issues with other devices also…

Would you mind share your android setup and permissions? what NDK you are packaging? are u using a different ndk from the one epic suggests?

I don’t have exactly the same issue that you have but it seems to be related: I have the same download screen excepts that the download doesn’t start, it says the message “No google playstore key, Obb not found” and that it can’t download the OBB file. But it means that in your case or in mine, there is an issue with the download of the OBB from the Play Store.
Sometimes I also get an error from Google Play when finished. It seems to happen if I try to download after a restart of my device.

I have tried also with UE 4.23 and 4.24 on a One Plus 6 and on a Sony Xperia (both running Android 10).

My permissions in the project settings are:

  • android.permission.ACCESS_COARSE_LOCATION
  • android.permission.ACCESS_FINE_LOCATION
  • android.permission.WRITE_EXTERNAL_STORAGE
  • android.permission.READ_EXTERNAL_STORAGE

For the last two ones I’ve head that it may solve the issue, but it didn’t change anything.

I’m using NDK toolchain r14b with NDK version 19. I think that’s the default settings because I didn’t change anything there.

I will also try to minimize the Play Store during the download to see if this changes anything on my side.

I tried minimizing the Play Store during the download. The behavior is changing a little but it’s still not working for me.

Still investigating on this issue. I’ve registered logs during the installation. I’ve noticed the following lines which seem weird:


03-14 15:39:18.918: D/OPBF(1275): pkg:com.isaratech.myproject is installed
03-14 15:39:18.919: I/Finsky(5552): [2] mqy.c(4): IT: Successful install of com.isaratech.myproject (isid: 4BV3HlgRRfqLxLsOX0W2Xg)
03-14 15:39:18.929: I/Finsky(5552): [2] mrg.a(101): IT: com.isaratech.myproject to state 70
03-14 15:39:18.930: I/Finsky(5552): [2] rba.d(9): Invalidating cached PackageState for com.isaratech.myproject
03-14 15:39:18.932: I/Finsky(5552): [2] mrg.d(26): IT: Cleaning up task: com.isaratech.myproject
03-14 15:39:18.934: E/Finsky(5552): [2] mrg.d(45): IT: Lost main obb file for com.isaratech.myproject
03-14 15:39:18.934: W/Finsky(5552): [2] mrg.a(232): IT: Cleanup running installation of com.isaratech.myproject (..obb_main)
03-14 15:39:18.939: I/Finsky(5552): [2] moq.b(18): Installer: stopping tracking of task: com.isaratech.myproject
03-14 15:39:18.941: I/Finsky(5552): [2] moq.a(184): Installer: Notifying status update. package=com.isaratech.myproject, status=INSTALL_ERROR

Hi, I got the same problem. Go to Project settings/Android and uncheck “Disable verify obb on first start”.
And anyway problem on my phone where I test game from editor (“launch on device”) when i downloading from Google Play (not downloading and not start), i think because some data exist on phone. On clear phone that download game first time it’s all work.
Regards.

IsaraTech, your issue might be google play setup for the key. The key you are using in your Build/Android/ has a unique SHA-1 . Also check that that SHA-1 from your key is been assigned properly to google play services.

Were you ever able to resolve this issue? I have noticed some users on Android 10 are receiving the same issue for my game.

I am also having this issue, @IsaraTech. were you able to solve it? @tamerbek I had “Disable verify obb on first start” unchecked from the beginning, it is still not working for me.

@IsaraTech. please answer, did you solved that problem?) It happens to my OnePlus 6T with Android 10, but works great on Android 9

Did anyone figure this out?

Working on this getting the same issue, i’ll let you guys know how to when i got it sorted

Hello,

I was also having this issue.

For me, it was resolved when I checked “For Distribution” in

Project setting -> Packaging -> Project -> For Distribution

Hope this helps someone :slight_smile:

I have found a way around this issue, is not the perfect solution but it might work for you, depending on your game.

I have had the same issues when trying to upload to Google Play.
and getting no.OBB Key Found.

My. APK file was 45MB and the.OBB 125MB
After discovering that Google Play has an application size of 100MB, I thought that maybe the error was coming because my .apk + .obb file was exceeding 100Mb

This is how I solved this issue
I had to go into my game and optimize every single texture I could, and deleting unnecessary animations, audio, and other assets.
I have used Texture size : 256px X 256px and for phone I think it looks great.

I also had to check the settings
Package game data inside the .apk? (true)
I was able to export a 99.6MB .apk file and then I uploaded it to Google Play.This had fixed the OBB Key Not Found for me. I was able to download the game from the store and play it perfectly.

Other Settings to help with Optimization
Package Settings-> Create Compressed cooked packages (true)
Android-> Force small OBB Files (true)

I have tried exporting the game without the game data inside the .apk and even both files not exceeding 100MB I could not make it work on Google Play.
Therefore I would recommend having the settings, Package game data inside the .apk? (true)
Of course, feel free to test with different settings.

If anyone finds a better alternative please share here, as I think this error could be from something else.
Just sharing what has worked for me.

你可以参考下默认的vr那个工程,保证一样就ok

Hello every I had this issue also.

Try uploading your game as an app bundle instead of two apks (second is arm64 version of your game)