No Find Session Results STEAM Online

Hey there,

just to make it short…I am not able to find any Sessions after creating them with the “Advanced Sessions Plugin”!

Information: I am able to connect with 2 (or more) clients in my editor. So i create a session and the other clients find it and can join.
Even on the check mark dedicated server or not! BUT after packeding it isnt possible! The Log means:

 UE4Editor-Cmd: LogOnline:Display: STEAM: Loading Steam SDK 1.32
 UE4Editor-Cmd: LogOnline:Warning: STEAM: Steam API disabled!
 UE4Editor-Cmd: LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()

To clarify: I did edit the “DefaultEngine.ini” with [OnlineSubsystem] and SteamDevAppId etc. I created the steam_appid.txt with 480. Means i get in editor aswell in the packed version the steam overlay!

Besides that, maybe i am totally missunderstanding everything and i have to buy a gameserver? Or am I right, that you are able to connect via Internet with the SteamOnlineSubsystem?

Reason is I already created my Game in a VPN-Connection soultion, (so connecting via IP-address), but i want to make it live so you can join over the internet.

Hopfully somebody can explain and even help me fixing the issue,
best regards PA :slight_smile:

hmmm not that easy to get behind your problem from that far away…

I am useing Steam Subsystem and the advanced session plugin in my project, too. And it is working, so i will try to tell you what i did, so that you can compare with your project, yourself.

DefaultEngine.ini: (like in the Epic Dokumentation mentioned)





In my MainMenu, there a two Buttons… one for Hosting that calles the following Event:
(Make sure your “Open Level” Node has the Option “Listen” in it. Otherwise your server does not care for any connections.)

And One for Joining, that calles the following Event:

If you test this on your own, you need to use two different Steam Accounts!!! And thats why you need two different physical machines.
I hope, that this helped you.

Remember that AppID 480 is related to Spacewars
so, your Find Session will search for ALL hosted Games under that ID. This results in a few thousand results, and your Finf Session can’t find the ones inside that mass, that is related to your Project.

So a Tipp:
Use Advanced Session.
When hosting, add your Gamename as Servername via Property String.
And in FindSession, look specifically for that Property, to filter your Game out of Spacewar.
And remember to raise the Max results to a higher value (around 1000… or more of needed)

Properties can be used as additional Filters, too. Perhaps, when you want to look for a specific Map only, or a specific Player.

1 Like

Oh, just a friendly reminder, you have to be logged into steam.
Several times I have sent a game to a friend, and they say they cant find my game… I would be like “what?” And start debugging, trying to figure out what was going on.
Turns out, they didnt log into Steam before testing the game… They just started the exe without steam running.

Also, you cant use the same steam account to test the game. You have to have two seperate steam accounts. So I made a steam account at work, with steam running, and Im testing lobby functionality from from there.

Ok guys,

thank you all for the information. I downloaded a test-steam project, and compared it with mine.
I finally found the issue:

I have no idea why this happend but this was the problem :S

Thx again for your help guys
Have a great day PA :slight_smile:

Yes, This happened when I did it as well. Its easy to overlook. Luckily, I noticed it when adding the create advanced session. :slight_smile:

For anyone with the same issue with the client not finding your server session, This is the solution! I set my max results to 20,000 and also used the game name as a property string. You can find an example in the example code from the advanced session blueprint. If this could be upvoted, I would do it!