No error message in log during crash

Hi,

When a game crash, we don’t have anymore the “error message” in the log.

As you can see in the error log just after, there are no message between fatal error and the stack trace whereas we usually have in 4.7 the error message.

Could you please confirm that you can repro that?

Log Sample:
[2015.08.12-20.13.16:517][352]LogWindows: === Critical error: ===
Fatal error!

ZB4Game.exe!UObjectBaseUtility::IsA() {0x00000001400385e1} + 0 bytes
ZB4Game.exe!AZB4DOMGameMode::RestartPlayer() {0x000000013f7c7028} + 27 bytes

Hey Elvince-

Are you working on Windows 10 by chance? If so this is a known issue of using 4.8 and Windows 10. Otherwise could you provide more information on what the issue is?

Cheers

Doug Wilson

I’m on Windows 7.

The issue I’m facing today is the lack of information when I have a crash in a cooked game.

Before 4.8, when the game crash for a “null pointer exception”, by example, in the log I had
Fatal Error : null pointer exception and the stack trace.

in 4.8, I have Fatal error … and the stack trace. The error message have disappeared.

It’s really annoying because you know where it crashed (function name in the strack trace) but you don’t know why it crashed (Null pointer exeption, buffer overflow, check(), AssertFail() …).

If you create a small project with an exec function that call a function of a null pointer, do you have the error message in the log of the cooked game ?

Could you send me the machine ID from the crash. If you submitted the crash I can use that to look it up for more information.

hi,

I miss your answer.
I didn’t submit any crash report because CrashReport is not added to cook project (even if we select the option but that’s another topics).

Can you confirm that’s on your side, in 4.8.3, the error message is in the log during a crash in a cook project?

thanks,

Hey Elvince,

I am in 4.8.3 and I have not received any sort of crash when cooking for Windows. Could you please provide us with the full output logs from the editor? Upload them to your next reply as a .txt file. Also, if a crash reporter does populate, please provide the full log from that too.

Thanks!

I’m sorry but I think you missread my issue.

I don’t have a crash when cooking.
It’s in the case we have a crash on cooked game that the error message is not in the log.

To repro this, just create a exec function in your player controller with the following body

AActor* Test;
FVector t = test.GetActorLocation();

When you are calling your exec in the cooked version, the game will crash because of the null point Test. In your log you won’t see the error message, just LogWindows: === Critical error: === Fatal error! and the stack strace

Could you please confirm the repro on your side?

thanks,

Elvince,

I was unable to reproduce this issue. I included all of the code that you provided and built the project in Visual Studio. I then went back into the Editor and cooked the content for Windows.

  • Could you please screenshot your error message?
  • Also, are you able to reproduce this on a new project of your own?
  • Have you tried 4.9 Preview 4 yet?

Looking forward to hearing back from you, thanks!

Hi,

Could you please share the crash log that you had so I can see what you got?
From your feedback, I’m not sure if you have launch the Cooked game (with the executable) and made it crashed by calling the Exec function.

In parrallel, I will try to get a repro on a new project but I will be very interesting to get your output on this.

Thanks,

Could you please screenshot your error that you receive? I need it in order to investigate the issue further. The small portion of error you provided previously is not enough to investigate this further to figure out the issue and enter a Jira if necessary.

Thank you.

Here is a print screen of the error message.

As you can see there are no error message except Fatal Error and the stack trace.

here you should have something like: “null pointer exception occured…”

Hey Elvince,

We’re looking into this issue further for you, we will contact back once we have additional information. Feel free to check up on this post at any time.

Thanks!

Hey Elvince,

Are you receiving an error code within the editor itself, anything that looks like the last screenshot in this post? If so, could you please provide it to us as a screenshot? The developers have also asked whether or not you’ve been able to get these errors to accumulate within the 4.7 version of the editor.

Thanks!

This very common for me since using Win 10, recent launcher updates have said better information willbe provided in the logs. Custom C++ code will of course always tell you errors/warnings and allow you to debug better.

Hi,

Im not sure that you properly understand my issue here. I m not in the editor. It s a cooked game that I m using and running. And when something bad happen and the game crash, the error message is not present.

The error message was properly filled in 4.7.

Thanks

Hi Elvince,

The developers specifically asked whether or not you were receiving any error within the editor or not. I understand that you are receiving a fatal error from a cooked version of your project, when you have: “AActor* Test;
FVector t = test.GetActorLocation();” built into your code.

I went ahead and regressed back to 4.7.6 and tested out the code to see whether or not I received a fatal error or not. I did not receive a fatal error with 4.7.6 however, I went and tested 4.8.6 and I received a fatal error but it’s not the exact same as yours.

With that being said, I have updated my email to the Developers regarding this issue and have heard back. Since this crash isn’t making it to the crash reporter, we would like to have you do the following:

-crashreporter added to the command line when cooking, or if packaging from the editor, there is a check box for the crash reporter.

Once you’ve gotten it to crash, and the crash reporter has populated, please copy the information and provide it to me so I can go ahead and search for it.

Thank you!

Hi,

Thanks for the time spent to find the root cause.

1 - In the editor, I have no specific error. Are you looking into something specific in the cook process log?
2 - during your testing on 4.7.6, did you receive the appropriate error message instead of Fatal Error?
You may not receive exactly the same error as me, but as you as you don’t have the real message in 4.8.6, we are on the same issue.

For the crash reporte, this is something that I wanted to report (and didn’t take the time) but we can’t add it into our cook. Even if the option is checked, the crash reporter is not added (I’m on a downloaded version from the launcher)

I check in my defaultgame.ini, I have: IncludeCrashReporter=True

Thanks,

Elvince,

4.7.6 did not have any fatal error or crash. I did run this back through on 4.8.6 and I received a fatal error. Are you unable to obtain the Source version of the Engine and include the Crash Reporter into your project so we can get to the bottom of this crash?

Thank you!

Hey Elvince,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

Hi,

Sorry for the delay.

I can’t test on a SourceVersion as of today. I don’t have it build.

What does the Crashreporter do more that the output log?
Are you looking for a dump file or somthing like that?
What information do you need so I can try to get them?

Doesn’t the repro project that you have on 4.8.6 is enough to track the issue?

Thanks,