No engines showing in Epic Launcher to install

Well I finally got the launcher to download and install, however, the Install Engine button does not list and engines to install. If I click the button I’m taken to the library page where you can choose which version to install. But, there are no engines listed. The drop down arrow next to the Install Engine button is greyed out as is the Plus symbol next to Engine versions. I have tries reinstalling, starting the process from scratch, I have logged out and back in, to no avail. I do log in with an Epic Games account if that makes any difference.
I have installed both Mixer and Bridge with no problems.
Any suggestions would be great, Chuck

1 Like
  1. Sign out of launcher
  2. go to c drive and create a new folder named ep or anything except its usual name Epic Games
  3. re-install launcher. If you get an error asking to repair or remove, click remove
  4. re-install launcher to new folder ep on your c drive
  5. everything should be updated including the correct engine and you should have a button to install UE in the launcher now

Thank you! Worked like a charm.

Hi there,
having the same problem. Followed the steps, but still can not install any version of unreal. What is the issue and how to fix it?

1 Like

This workaround is a life-saver but
Why is this still happening thou.

This workaround isn’t working for me either! Has anyone found another fix?

I’m having the same issue, I’ve contacted support, I’ll let you know what they say.

I just checked the launcher again and it was there this time. I’ll still put the help request through because this shouldn’t be happening at all.

I have same problem. Any solutions?

interestingly it appeared on its own after a few minutes

Helped also for me. Thanks for the tipp.

same It doesnt appear for me. I want 4.25.3

Can’t seem to install Unreal. The install engine button just opens the library tab but then the + is greyed out. I thought maybe I had to download from the website but the download link just downloads the installer for the Epic games launcher. I’m really baffled.

1 Like

I fixed it by running Epic Game Launcher as Admin, then I’ve clicked on install and the engine appeared to install. That fixed it for me.


After doing various uninstalls, reinstalls etc… the only thing that worked for me was signing in directly with epic games rather than google

Same issue here. Did the reinstall tip told here, also re-log with epic account directly as 09_caylido told.

None worked for me. Still gray plus button

i tried all the following methods above, still can’t see any UE available to install (in my pic)
is this a bug? why so many people have this issue and its still not fixed over the years

You can use the UnrealEngineLauncher.exe which should be found in C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64\UnrealEngineLauncher.exe
Double click on the exe file and it will appear in the Epic Games Launcher as an option to install the program.
I hope it helps

I tried all the above suggestions, but nothing works. unreal engine does not show up for installation. Does more people have this problem?

The same here for me. I have tried all the above suggestions, but still getting the grey plus button.