No Compiler was found

When I try to make a C++ project it says that no compiler was found, and that I must install Visual Studio 2017, then gives me a link to do so. However I already had VS 2017. So I uninstalled it and reinstalled it using the link. That didn’t fix the problem. I have tried uninstalling and reinstalling UE4, but still that didn’t fix the problem. I have ensured that I have all the proper components for VS 2017. I have made sure that in the editor config VS 2017 is set to be used. Have tried generating the visual studio files in the project folder but that wouldn’t work. How can I fix this issue?

Same for me… have already tried to uninstall everything and reinstalled everything… but that doesn’t work.

I tried to install VS 2015 next to VS 2017 and with that I was able to open the project file in VS 2015 what gave me an incompatible error (UE 4.20). Even when I changed the settings in the editor preferences to VS 2017, it opened VS 2015, where I can’t edit the files as I said.

Any solution that may work?

You have to include VS2017 plus Windows SDK, C++ runtime libraries, and Native development toolkit.
You should make sure those “checkboxes” are ticked when you install Visual Studio (on its installer app)

Okay, I installed Windows SDK 8.1 and Windows 10 SDK (10.0.16299.0) for UWP and for Desktop C++ as well as the packages Desktop Development with C++, .NET Desktop Development and Game Development with C++.

What do you mean with native development kit?