Download

No Compiler Was Found. UE 4.18 VS 2017

Hi,

I’ve been using UE4 for a bit now, and tried to download CLion integration, eventually I saw that it was going to be added in 4.19 so I decided to try and go back to the basics (even though I hate using VS).
I tried the following:

  • Re-installing (removed and then installed) UE4.18.
  • Removing VS from my PC (I had 2015 & 2017, removed them both and then installed just 2017 using the ue installed).
  • Verifying UE 4.
  • Removing VS 2017 and installing 2015.
  • Installing all the needed things (WinSDK 10 & 8.1 several times).
  • Putting the VS in Program Files (x86).

Nothing seems to work and every time I just see the same annoying error
“No compiler was found…”

What do I do?

A couple of extra notes:

  • Worked before I tried to use The CLion integration (downloaded as a plugin).
  • Worked with VS 2015.
  • After deciding not to use CLion for now, started to ask me for VS 2015.
  • UE 4.17.2 works just fine.
  • When I removed VS and reinstalled it, I used the installer and left everything as is, and when I clicked “OK” in the dialog that says “Click OK once you installed VS 2017” It just popped the dialog back up again.
  • UE 4.18 is installed on an SSD on drive C, and VS 2017 is installed on drive F.

Thanks in advance,
Alon.

Hey, i have same problem here. Now i’m trying to reinstall Unreal Engine and Visual Studio. If that will not going to work, propably downloading source code and compiling it by myself.