Download

"no compiler found" Qt Creator

Hi,

I tried to use the editor with qtcreator. But i get the “no compiler found” Message.

I compiled the editor from branch 4.10 and downloaded the QtCreatorSourceCodeAccessor, changed the line in Engine/Config/Linux/LinuxEngine.ini and did the
make UE4Editor
but the editor crashed b/c the Accessor wasn’t compiled, but a
make UE4Editor ARGS=-clean
make UE4Editor
seemed to fix that.

When I create a new C++ project i get the “no compiler found you must install a IDE” Error.
My search revealed, that this happens when you have no Accessor installed, but it is, it even appears in Edit->Editor Preferences->Source Code->Source Code Editor and Edit->Plugins->Programming
and qtcreator itself is ofcourse installed.
Can someone point me any further?

System is manjaro with
clang 3.5

hm,

I tried KDevelop. There the no compiler Error don’t shows up, but when i open it from the Editor, it opens two empty (new) files:
~/Documents/Unreal
~/ue4-editor/UnrealEngine/Engine/Binaries/Linux/Projects/<projectname>/<projektname>.workspace

There seems to be a problem with the space in “Unreal Projects” but even open it manually only opens it as a plain text instead of a Project.

The only working solution seems to be, to use CodeLite…
But at least that worked…
Is it the current state, that only CodeLite works or am I missing something on my side because both
https://wiki.unrealengine.com/Linux_Known_Issues and GitHub - fire/QtCreatorSourceCodeAccess
lists Qt Creator (and Kdevelop) as working.

EDIT or not…
Only first opening the Editor with KDevelopSourceCodeAccessor in LinuxEngine.ini and than switch to CodeLite in
Edit->Editor Preferences->Source Code->Source Code Editor
seems to work oO