No colour on UI

the pictures dont show it but id would presume that you lowered the saturation somewhere.


I’ve setup basic UI such as ability bar, minimap frame, player health bar etc.

But when I run the game, the UI isn’t coloured. Mostly everything except from my ability bar, should be a goldish colour, and it appears gold in the widget blueprint, but it turns out grey when i run the game? Any help would be appreciated, thanks.

I’m trying to think of a way to do it like OP did, so I can think of a way to undo it but I’m failing…

  • the canvas can’t override content colour
  • if your images were inheriting foreground colour from the widget’s root, it would show in the Designer as well

Do you have any other widgets on top that could alter the UI colour? There is a Widget Reflector button next to the Play button. Run you project, launch the reflector and hover over the UI - check in the reflector window whether you’re interacting with something unexpected.

I am on the third person person project, in a new level . Then I have set up what I showed in the screenshot, those are the only significant changes to anything UI or blueprint related.
Also when I created a 3rd new level, the UI is coloured.

I assume this means theres some setting in my level that’s disrupting it? Even though ive hardly changed anything. Also when I use the widget reflector on my non coloured UI, it says under ‘visibility’ tab, “SelfHitTestInvisible”.

I think my saturation is fine, I’ve tried changing it with no results.

it says under ‘visibility’ tab,

That’s fine, that’s most likely just your canvas, most likely - you should see the name of this widget in the reflector.

Apart from the 2 bullet-points I mentioned, I can’t think of anything that could desaturate the UI like this. But there surely are elements in the engine I’m unfamiliar with.

One more question. This UI of yours, is it a normal widget, you’re not displaying it through a widget component by any chance?

edit: also I absolutely love the fact that you referred to it as goldfish colour.

No its just a normal widget blueprint, Ive been fiddling for a while now and still can’t find the problem. Does lighting affect UI? It really most likely doesn’t, and it wouldn’t make any sense, but I’m just going to ask anyway haha. I haven’t built the lighting but its probably unrelated anyway.

You’re right, lighting does not affect UI. It could affect widget components (or it used to), hence my question above but that’s not the case.

Hm, so what are the orbs in the middle? This is a part of UI, too?

That’s fine thanks anyway, and yeah they’re just images. Its annoying because Unreal knows they’re meant to be coloured, they’re coloured in the widget blueprint. I tried the same UI in a new level and it worked, and I haven’t changed anything but I guess it must be level specific.

Ah ok
And no the orbs are part of my character model.

I am a bit stumped then! Gonna hang out here until someone figures this one out. Cool puzzle.

The best clue here is that it works in some levels only. Sorry I could be of no help.

edit: and your images are just images? They’re not materials or anything fancy?

I ended up finding out how to avoid the problem. Remember how I said that the UI was being coloured right in a separate level? I just duplicated that widget blueprint and brought it to my main level where my UI is now being coloured properly. This doesn’t explain why the original UI wasn’t working, but I at least got it working. Quite a simple fix that I didn’t think of whoops.

Ha, on one hand I’m glad you found a way to fix it, on the other one, I’d like to how you managed to desaturate the UI like that.

Perhaps it should be added to the list of UMG quirks. :expressionless:

Good luck with the rest!