No collision without gravity


I’ve got problem with collisions. What I want to achive in my game is an adventure game where backgrounds are 2d, and objects(character, inventory objects) are 3d. To achieve moving of player in such a kind of space I had to write my own movement without using CharacterMovement(tough I’m using the template). It’s a simple rule. The more player will hold “W” key, the more character will scale down and go in Z axis. And for this I’m using Set Actor Scale, and Set Actor location Blueprints.
Here’s what I mean:




But i want a collision where the building starts, so what I tried to do is to give a cube as a child to mesh in Character blueprint and give everything no collision except this cube:


Capsule collisions:


Mesh collisions:


And cube has BlockAll

But unfortunately this doesn’t seem to work. I’m not using Physic simulation and gravity from CharacterMovement is set to 0. Can it be that without physic simulation there is no collisions?

are you definitely sure your wall mesh has a collision primitive?

Yes. When I use default CharacterMovement(with gravity set to 1 and collisions for capsule component on) my character collides with wall.

Hmm would it be possible to keep gravity and make him fly instead?

I tried it now. Can it be that because i set Walk/Fly speed to 0 in my blueprint? Cause when I set speed even to 1 collisions suddenly work. I’m setting new location by SetActorLocation
I’ll try it tommorow.