No collision in the Zen Garden

As a learning experience, I am trying to make the zen garden into a level playable level that I can run around in with the mannequin. Yes, I loved it that much. So I managed to get a third person player start working but the problem is that I can’t find a single solid surface that the mannequin can stand on. He passes straight through and falls down into infinity. As far as I can tell, almost everything has a collision mesh defined so I don’t understand why it doesn’t work, even when I change the preset from Default to BlockAll. If I add my own surfaces, such as the Shape_Plane from the engine content, it works perfectly without me changing anything. I can just drag a plane it into the level, right click on it and ‘Play From Here’. However if I right click on the roof of the house, or the garden or the wooden terrace, he just falls. I don’t get it.

Hi,

This would be a good place to start for adding collision to these meshes: Collision | Unreal Engine Documentation

Zen Garden was developed for as a very specific demo and did not need collision for the meshes in order to work. That would have been additional overhead for something not needed. Following the documentation above to generate collision hulls for the meshes in Zen Garden.

-Tim

Thanks for your reply Tim. Yes I am already aware of the documentation pages. They have not really helped me in this case. Since the mannequin works correctly and other meshes from the engine content work correctly without changing anything, the issue has to be with the static meshes in the zen garden. I cannot find a setting that works at all. Can’t you tell me what that setting is? The documentation implies that all I need to do is choose BlockAll for both my pawn and the static mesh and it will work. But it does not, even if I select ‘Simulation Generates Hit Event’. The example isn’t great either - why would my wall be WorldDynamic and not WorldStatic? Is the wall supposed to move? And why does it say the wall is WorldDynamic but the screen capture highlight WorldStatic instead? Plus the sphere has a ‘Collision Preset’ of None. Then the sphere has ‘Collision Enabled’ but the wall has ‘Collision Enable (Query and Physics)’, without any explanation of why or what they really mean. I can’t find any tutorials that really cover it properly either.

You’ll need to generate collision.

Follow any of the top three listed on this “How-To” page from the documentation I linked: Collision How To's | Unreal Engine Documentation

The meshes do not have collision and will need to have it generated. The other settings you’re pointing to are more for the character or dynamic objects and how they interact. This too is covered in the documentation looking at how to generate collision responses, but without collision hulls setup for the mesh those settings are not useful.