No Cast to X show up but already is in BP HELP!

Can some please help! I cannot find any help online, I already tried restarting Engine, deleting all save files from project but no Custom Anim Blueprints show up ever, even though in the example VR Project the Controller BP already has a Cast to RightHand_AnimBP and it works fine but I am unable to use any other anim blueprints. And if I were to accidentally delete the “Cast To RightHand…” then I would not be able to get it back!

I am unable to get any progress on my Animations please I really need help!

I cannot cast to any blueprints that are not default ones, not even the Cast To RightHand_AnimBP that was already in this BP from the default VR Project (as you can see in the screenshot). Will look into source control/tree though!

it should be there,
what file are you trying to cast to?
can you see the file in the content browser?
tip : learn source control/ source tree

It matters where you drag off from, just try dragging from out from somewhere else or untick content sensitive.

I tried different blueprints, 20 different things/places to drag off, tried turning the context sensitivity on/off and tried just right clicking in empty space, but nothing.

strange,
i guess then you would need to copy-paste that node every time

Thats what I do now, but I am unable to use any other animation blueprints for other meshes.

Hello Rolandem,

This actually looks like a bug. We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.
https://epicsupport.force.com/unrealengine/s/

From,
Zack Henderson

Hi,

I can just confirm that this problem exists also for me (version 4.23 P5).

Edit: Just tested with version 4.22.3 and it is working like expected.
Cheers