No bloom in android

I want to use bloom in my game. The bloom effect is working fine in iOS devices but there is no bloom effect in android.

I set +CVars=r.BloomQuality=1 in both engine’s BaseDeviceProfile.ini as mentioned in the documentations.

Do I have to set anything else to enable bloom effect in android?


Hey e.sabouri,

Depending on your device, you might not be able to utilize certain post processing HDR effects like ‘Bloom’.

You can take a look at our Android Device Compatibility list to see where you device falls on that list and if it is supported.

Let me know if you have further questions.


Hi Andrew,

I’ve tested my game with HTC one m8 and the bloom effect works, but on my other devices (Samsung Galaxy S5 and Samsung Note5) which are supporting HDR in the documentation the bloom not works.

Isn’t there any way to utilize bloom on Galaxy S5 or Note5?



So I have been running some tests and can confirm that the Galaxy S5 we have here as well as the Note 10.1 is not showing Bloom as expected. I was able to deploy to a different device (iPad) and bloom was working just fine.

I am currently looking into this more to make sure Bloom is correctly displaying on the higher end android devices as you are reporting, since the Galaxy S5 is stated to work with Full HDR in our documentation.

Update: I have completed my testing and entered a bug for the issue (UE-26892). Bloom is not functioning correctly on the Samsung Galaxy S5 device as the documentation suggests it should.

Once a fix has been implemented it will be merged and integrated for an upcoming full engine release or hotfix, and then added to a the list of known and fixed issues.

Thank you for your patience and let me know if you have further questions.


Unfortunately the Galaxy Note 10.1 and Galaxy S5 with Mali T-6xx GPUs do not support “floating point framebuffers” or the “framebuffer fetch” OpenGL ES extensions, so UE4 cannot support bloom on these devices.

However it should be working on Galaxy Note 5 and Galaxy S6 both of which use a Mali T-7xx GPU and have the one of extensions we need. I will get QA to try reproducing this issue on a Note 5.

Could you provide the android version you are working on?

Hi Andrew,

The Android version on Note 5 is 5.1.1 and on Galaxy S5 is 5.0

Thank you. We weren’t able to get a hold of the Note 5 as that device currently is not in house, but we tested on the Samsung Galaxy S6 which shares the same GPU, and bloom was working as expected on that device. Unfortunately we have reached the limit of what we can test.

We placed an order to have the Note 5 delivered to our compatibility testing department so we can test when it is ready. We appreciate you taking the time to test this issue, and once the device has been delivered we can look into testing the issue further.


We tested a Galaxy Note 5 running Android 5.1.1 with both Unreal Engine 4.10.1 and 4.11.0 from the launcher and bloom worked correctly.

Hello ,

I have been having a similar issue in getting the Bloom to work on Android.

I am currently using a Galaxy Note 5 and while the bloom appears well in the UE4 editor, when I play on the phone there is no bloom effect.

Could you elaborate on how you tested the Note 5. I must be missing something with bloom.

I have it enabled and mobile hdr enabled in the settings and have a post process volume.

Currently running 4.10.4


Hi ,

I believe we’re seeing an issue with this device where bloom is working but is very weak. We’re tracking this issue with ticket number UE-28618.

Can you try increasing an emissive value so that it’s really, really bright and then checking to see if the device is doing any bloom at all?


Hi ,

Thanks for the info here.

I did go ahead and crank everything up to “11”, if you will. It did start registering the bloom on the device. In my opinion its a little messy but technically it is there.

Out of curiosity, is there any new info on this ticket or plans moving forward?


That bug is scheduled to be fixed for 4.12.