No angular constraint visualization in physics constraint

Since 4.11 angular constraints of the physics constant are not shown in the viewport.

In 4.10 they were clearly visible:

Steps to reproduce:

  1. Start new project in 4.11
  2. Add new Actor or Pawn blueprint
  3. Add two static mesh or primitive components
  4. Add physics constraint component
  5. In physics component, constraint two components added earlier
  6. Set angular limits to limited - this is where in 4.10 limits were rendered as circle segments.

Quick sanity check: On the physics constraint is Visible checked?

Yes, changing Visible or HiddenInGame has no effect on this.

Epic! Your turn! :wink:

Hey BoredEngineer,

Thank you for the report. Yeah, this seems like a bug unless something changed behind the scenes that I didn’t know about. I’ve created JIRA UE-29503 and our developers will be investigating this further.



They are also not visible inside the physic assets. So I guess they are not visible everywhere! Really annoying since with this numbers it is very abstract and I have no clue what swing1 is and what swing 2 is.

For now, the horrible workaround that I’ve found is to go into PhAT_JointLimitMaterial (Engine Content. Engine\Content\EditorMaterials\PhAT_JointLimitMaterial.uasset) and change the Blend Mode from Translucent to Opaque. They will show up and be workable, but, you know, opaque. Not a huge deal, and it allows me to keep working.

Everything else that I’ve tried shows the constraint discs black for a second (while shaders build) and then, as soon as they’re done, they disappear.

I know that this is somehow related to the project, as I was able to (with the same executable) see those discs (on the same asset, SK_Mannequin), but not when trying to view them in my project. Some view setting must be different nowadays. I’ve tried using Reset layout, to no avail.

For now, I’ll have opaque constraint limits.