No AdMob Banner Ad

I posted this over at the Answers site but no replies: No AdMob Banner Ad - Programming & Scripting - Epic Developer Community Forums

I tried using Show Ad Banner in my blueprint but nothing appears. So far these are the things that I’ve done:

  • Filled in everything under Android section in Project Settings
  • even tried using the AdMob Unit ID from Tappy Chicken but nothing
  • Called the Show Ad Banner node from Level Blueprint, a UMG button, and even from an actor’s BP
  • Published my app to Alpha on Google Play, and linked to it in AdMob
  • added the following to the DefaultEngine.ini
    [OnlineSubsystem] DefaultPlatformService=GooglePlay

I’m also unable to call the Achievements Screen. I’m linking a button click event directly to a ‘Show Platform Specific Achievements Screen’ node and a ‘Get Player Controller’ node. Any other nodes I missed out?

Have I missed anything? Builds are all successful and no problems with my Google/AdMob account.

Do you login to google play with show external ui node before you try to get achievements or show ads?

No I did not…I’m still new to all this so I didn’t even know what other nodes are needed! I tried adding it in Level BP at BeginPlay but returns On Failure. How do I use it? A quick google on the node doesn’t reveal much. I don’t see it in Tappy Chicken as well but it was able to display banner ads.

I would do all of it in game mode Bp. Level bp only works in that one level.
Go to game mode and get player controller. Drag out a pin from player controller and get node is loged in. Drag a pin from is loged in and get a branch.
Get node show external login ui and connect it to false. So now if player is not logged in, you will login and if already loged in you don’t.

I found this pic on my phone on how it looks. I dont remember where I took it. Here it is:


I took the pic from another post on these forums when I was stuck.

Ok so I finally had a chance to try it out but still failed to see the login UI. Interestingly, my Print String nodes fire when simulating in UE4, but doesn’t appear in my published Alpha version on Google Play; as in I don’t see the texts appearing. I tried this in my Game Mode BP and also a UMG button.

By the way, I’m using separate game modes for my menu screen and my game levels. Hope that doesn’t affect anything.

And I included a ‘does save game exist’ node after the sequence node. Should it be BEFORE the checking logged in status?