No ability to assign a level to level streaming volume

I have been struggling with this for a couple of days now. Every single resource I have been able to find must be out of date or something is just very wrong on my end. I cannot assign a level to a streaming volume. Every answer to this question seems to be to go to the levels window and open the level details, then just assign the volume. However the picture always shown as an example is completely different than what I see. Getting pretty frustrated. Please tell me, where in this picture do I have that option?

From your screenshot, it really looks like you’re using an older version of UE4. Something prior to 4.10. This is what 4.10 - 4.12 look like:

Your screenshot looks like it’s from a very old version of the engine.

Well my launcher says I am running 4.12.5, so not really sure how thats possible. I guess I am gonna try and run a clean install and see what happens.

Yup. Still showing that ui for me. Even though I uninstalled and completely cleaned out my files, downloaded fresh from launcher. Here is my about ue4.

That’s odd. Do you want to send along your project and I can try opening it tomorrow to see what the level info UI looks like?

The problem is that it’s not the project that’s the problem. I have deleted and started one from scratch multiple times. All I am doing is making a new project using the third person template, then making a new level, and turning world composition on.

Oh, you’re using World Composition. That’s the difference. I’ve never used that mode of streaming because it’s meant for very large (expansive) worlds. I just tried enabling it and now see what you’re seeing.

It looks like World Composition uses a different way of streaming in levels automatically. Here’s the doc:

Take a look at the Layers section where it talks about auto streaming based on distance vs. manual streaming via BP.

If your game isn’t expansive, you can turn off World Composition. If you do that, you’ll see the Streaming Volumes array appear under the level info.

Ahh okay, thanks.